Bug 493658 - Cannot change external display between VGA and DVI.
Cannot change external display between VGA and DVI.
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-02 10:37 EDT by David Woodhouse
Modified: 2010-06-28 07:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 07:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
tarball of debug output (76.75 KB, application/octet-stream)
2009-04-18 13:25 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2009-04-02 10:37:15 EDT
My MacBookPro4,1 has a GeForce 8600M GT.

It has an external DVI port, and comes with a DVI->VGA adapter.

I've been testing it with my Panasonic TV, which can take either DVI or VGA input.

I can use xrandr to enable the external display, with either of the two cables I have attached to it (using digital or analogue output). I can disable the display, and re-enable it again. All is well... although occasionally I've seen 'xrandr --output DVI1 --right-of LVDS1' fail with a 'BadMatch' error.

Most of the time it's fine though... until I _change_ cables (change between digital and analogue output on the DVI port).

Sometimes when I run 'xrandr --auto' after changing the cable, it crashes. Other times, it claims to have worked, but I get nothing on the screen. I have to reboot to change between the two. I see '[drm] i2c and hpd detect differ: 1 vs 0' in the kernel output.
Comment 1 Adam Williamson 2009-04-17 14:58:59 EDT
Can you post the full /var/log/messages (indicating when you did what, to compare against the timestamps, would be awesome) and also /var/log/Xorg.0.log? Thanks.
Comment 2 David Woodhouse 2009-04-17 21:11:28 EDT
Hm, seems to have regressed -- I can't get DVI output to work at all any more; only VGA. At http://david.woodhou.se/nv-crash.gz there's a kernel log with drm.debug=1 of what happened when I used gnome-display-properties to successfully enable the VGA output, then attempted to switch to DVI mode.

(It's actually the same external monitor, well, television, both times -- just through a different cable).

It's a big file. The fun part is at 
Comment 3 David Woodhouse 2009-04-17 21:14:30 EDT
When I try to enable DVI without previously using VGA output, the failure mode is different. It doesn't work, and the X server gets very unresponsive. I see this in dmesg:

Apr 18 01:44:47 macbook kernel: [drm:drm_mode_getfb] *ERROR* invalid framebuffer id
Apr 18 01:44:47 macbook kernel: [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on crtc ffff88013cd30000
Apr 18 01:44:51 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010081
Apr 18 01:44:59 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010c81
Apr 18 01:44:59 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010c9d
Apr 18 01:44:59 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010081
Apr 18 01:45:01 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010c85
Apr 18 01:45:04 macbook kernel: nouveau 0000:01:00.0: timeout: 0x610300 = 0x80010c9d
Comment 4 David Woodhouse 2009-04-17 21:16:13 EDT
I'm now using kernel- and xorg-x11-drv-nouveau-0.0.12-26.20090413git7100c06.fc11.x86_64

When the bug was first filed, I'll have been using whatever was current at the time. Should I go back and attempt to reconfirm that DVI was actually working with those versions?
Comment 5 David Woodhouse 2009-04-18 13:25:13 EDT
Created attachment 340166 [details]
tarball of debug output

DVI output _is_ working with kernel and xorg-x11-drv-nouveau-0.0.12-29.20090417gitfa2f111.fc12.x86_64. Given that I was debugging at 2am I probably did something stupid like leaving the TV on the 'PC' input rather than switching it to 'HDMI2'. Small wonder I didn't get a DVI picture if I didn't ask the TV to show it to me.

Attached is a tarball with drm.debug=1 output from various attempts. First I boot up, enable the DVI output, then switch to VGA. DVI works, VGA fails (and in fact when I connect the DVI connector again, I still get a picture. (Yes I remembered to tell the TV which I wanted to see this time, as I changed cables.)

In the second directory, I do it the other way round. VGA first (which works), and then DVI (which gives me an oops).

In the third directory, there's Xorg.0.log with --logverbose 255 from the nv driver as I successfully switch back and forth between DVI and VGA.
Comment 6 Adam Williamson 2009-04-20 16:46:38 EDT
Thanks a lot.

Fedora Bugzappers volunteer triage team
Comment 7 Bug Zapper 2009-06-09 09:06:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 8 Matěj Cepl 2009-11-05 13:24:54 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 9 David Woodhouse 2009-11-05 13:58:15 EST
I'm still having problems when I go from DVI-D to VGA (actually DVI-A) output.
Comment 10 Bug Zapper 2010-04-27 09:27:07 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 11 Bug Zapper 2010-06-28 07:39:49 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.