Bug 493683 - Unhandled exception at the end of installation of F11Beta error ejecting cdrom
Unhandled exception at the end of installation of F11Beta error ejecting cdrom
Status: CLOSED DUPLICATE of bug 492459
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 12:36 EDT by Markku Kolkka
Modified: 2009-04-12 00:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 12:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log file (212.66 KB, text/plain)
2009-04-02 12:36 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2009-04-02 12:36:01 EDT
Created attachment 337846 [details]
Anaconda log file

Description of problem:
At the end of installation process after all packages have been installed, Anaconda shows a dialog about an unhandled exception.
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 2687, in eject
    log.warning("error ejecting cdrom %s: %s" % (device, e))
  File "/usr/lib/anaconda/installmethod.py", line 47, in doMethodComplete
    dev.eject()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1338, in handleRenderCallback
    self.currentWindow.renderCallback()
NameError: global name 'device' is not defined

Version-Release number of selected component (if applicable):
11.5.0.38

How reproducible:
always

Steps to Reproduce:
1. Proceed normally through the installation procedure using the x86_64 install DVD
  
Actual results:
Error message at the end.

Expected results:
System reboots to the installed OS.

Additional info:
VMware server 1.0.8 64-bit client on Fedora 8 x86_64 host
Comment 1 Chris Lumens 2009-04-02 12:54:11 EDT

*** This bug has been marked as a duplicate of bug 492459 ***

Note You need to log in before you can comment on or make changes to this bug.