Bug 493686 - iwl3945 failures: Not a valid iwl3945_rxon_assoc_cmd field values
iwl3945 failures: Not a valid iwl3945_rxon_assoc_cmd field values
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 12:53 EDT by Christopher Aillon
Modified: 2010-03-26 10:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-26 10:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2009-04-02 12:53:29 EDT
After I log in to VPN, within 30 seconds, the connection goes completely dead.  I cannot connect to anything new.  Additionally, if I log out of the VPN, my network is still useless until I re-associate with the WAP.

% uname -r
2.6.29.1-37.rc1.fc11.x86_64
% rpm -q iwl3945-firmware vpnc NetworkManager NetworkManager-vpnc
iwl3945-firmware-15.28.2.8-3.noarch
vpnc-0.5.3-3.fc11.x86_64
NetworkManager-0.7.0.99-5.git20090326.fc11.x86_64
NetworkManager-vpnc-0.7.0.99-1.fc11.x86_64

Hardware: http://www.smolts.org/client/show/pub_443df9ec-58f1-4b0f-9dce-42d30ae2a44f

syslog shows these 5 lines repeating around 3 times per second until I kill the connection.

Apr  2 08:06:51 localhost kernel: iwl3945: check TGG and auto detect 1 | 1
Apr  2 08:06:51 localhost kernel: iwl3945: check antenna 2 1
Apr  2 08:06:51 localhost kernel: iwl3945: Tuning to channel 36
Apr  2 08:06:51 localhost kernel: iwl3945: Not a valid iwl3945_rxon_assoc_cmd field values
Apr  2 08:06:51 localhost kernel: iwl3945: Invalid RXON configuration.  Not committing.
Comment 1 Christopher Aillon 2009-05-21 18:46:09 EDT
Note that this is actually not a specific VPN issue, however VPN exacerbates it.  Upon further debugging whilst in Westford with Dan, it seems that the nullfunc patch from bug 493745 is not present in Fedora 11, and adding that patch seems to help so far from my limited testing.
Comment 2 Dan Williams 2009-05-21 18:56:36 EDT
fyi the "fix" for this is a9a6ffffd05f97e6acbdeafc595e269855829751 from wireless-testing.  It works around the problem by fixing the trigger, which is the AP deauthenticating the station when the station returns from scan because the station didn't actually send the nullpacket when beginning the scan.
Comment 3 John W. Linville 2009-05-22 13:33:56 EDT
FWIW, that fix is in 2.6.30 since -rc1...
Comment 4 Bug Zapper 2009-06-09 09:07:34 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Stanislaw Gruszka 2010-03-17 03:24:06 EDT
Fedora 11 had update to 2.6.30 kernel, so that bug should be fixed.

Christopher, do you confirm that?
Comment 6 Stanislaw Gruszka 2010-03-26 10:54:54 EDT
Ok, I assume this is fixed.

Note You need to log in before you can comment on or make changes to this bug.