Bug 493701 - (ibus) imsettings disconnect/reconnect kills gtk app
(ibus) imsettings disconnect/reconnect kills gtk app
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-04-02 13:46 EDT by Warren Togami
Modified: 2009-04-07 00:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 00:43:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-02 13:46:58 EDT
imsettings-0.106.1-2.fc11.x86_64
gtk2-2.16.0-1.fc11.x86_64
ibus-1.1.0.20090331-1.fc11.x86_64

* imsettings > Show status icon
* Run application like xchat
* Begin typing in a language like ibus-korean, leave it in pre-edit
* Click disconnect and reconnect on the imsettings-applet

**
IBUS:ERROR:ibusimcontext.c:584:_bus_connected_cb: assertion failed: (IBUS_IS_IM_CONTEXT (ibusimcontext))

Application crashes with this message.
Comment 1 Akira TAGOH 2009-04-05 20:45:14 EDT
Warren, do you use the focus-on-click mode for window manager? or you have never touched any configuration with gnome-window-properties say? please check /apps/metacity/general/focus_mode gconf key if you use metacity.
Comment 2 Warren Togami 2009-04-05 20:50:48 EDT
click

I don't recall changing any settings.
Comment 3 Akira TAGOH 2009-04-05 21:44:09 EDT
Thanks. well, imsettings doesn't do any real work to switch immodule but just sets the gconf key and gtk+ changes it on the focus change. I haven't looked at the source code for ibus immodule though, I guess it may assumes an input context is valid after focus is coming back?

or this needs to be confirmed, if this won't happens with a step like 1) disconnect 2) back to apps 3) reconnect again with imsettings 4) back to apps again, gtk+ might just reuse a old instance since it may looks like no immodule changed because unfortunately there are no implementation so far in gtk+ to update immodule except on the focus change.

ideally IM change would be applied immediately to resolve an issue not destroying old IM process. but ibus could has a workaround to validate if an input context is sane and reconnect as needed.
Comment 4 Peng Huang 2009-04-07 00:43:51 EDT
I fixed in ibus-1_1_0_20090407-1_fc11. Please test it.

Note You need to log in before you can comment on or make changes to this bug.