This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 493705 - When client using iec958: dies abnormally device is not switched back to analog
When client using iec958: dies abnormally device is not switched back to analog
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 14:43 EDT by Vlad
Modified: 2010-06-28 07:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Start PulseAudio (52.83 KB, text/plain)
2009-04-03 03:09 EDT, Vlad
no flags Details
Profile changing (15.52 KB, text/plain)
2009-04-03 03:09 EDT, Vlad
no flags Details

  None (edit)
Description Vlad 2009-04-02 14:43:46 EDT
Description of problem:
Sound disappeared after some times changing "Profile" in Volume Control. I have tried to repair it by return working profile, but unsuccessfully.
"pulseaudio[3602]: alsa-util.c: Cannot find fallback mixer control "PCM" or mixer control is no combination of switch/volume." appeared in message logs.

Version-Release number of selected component (if applicable):
pulseaudio.x86_64                        0.9.15-8.test7.fc11
kernel.x86_64                            2.6.29-16.fc11 
alsa-lib.x86_64                          1.0.19-3.fc11

Steps to Reproduce:
1. Play some music file
2. Volume Control
3. Configuration
4. Change profile up and down
3. Error: "Connection failed: Connection terminated"
Comment 1 Lennart Poettering 2009-04-02 17:42:32 EDT
Sound disappeared? Maybe you switched to the "off" profile?

The log message is purely informational. You can safely ignore this.
Comment 2 Vlad 2009-04-03 03:08:32 EDT
Yep, Definitely there is no sound. :) No, my profile is "Output Analog Stereo + Input Analog Mono". I have tried mplayer through oss, but same result.

My card is "Creative Labs SB Audigy". I'm sure it works, because i have tested it with livecd.

There are two logs from "pulseaudio -vvv". First is just start, second is changing profile from "Output Analog Stereo + Input Analog Mono" to "Off" and back.
Comment 3 Vlad 2009-04-03 03:09:16 EDT
Created attachment 337985 [details]
Start PulseAudio
Comment 4 Vlad 2009-04-03 03:09:50 EDT
Created attachment 337986 [details]
Profile changing
Comment 5 Lennart Poettering 2009-04-03 11:32:20 EDT
I assume by by "no sound" you mean that the apps appear to assume that they play audio except that you cannot hear anything? Have you played around with 'alsamixer -c0'?

If mplayer bypassing PA has the same issue then this is unrelated to PA.
Comment 6 Vlad 2009-04-03 12:29:37 EDT
Yes, u are right about what i assumed. :) Also you a right about 'alsamixer -c0', i have didn't know about it. The problem was in "Audigy Analog/Digital Output Jack", it was "On". It seems, that after fault this option has changed. As i can remember in F10 this parameter was in gnome mixer.

Thank u! Now i have sound. :)
Comment 7 Lennart Poettering 2009-04-03 12:40:42 EDT
Hmm, seems to be a mixer default initialization issue. alsa-utils should set up the mixer hw up by default so that everything works. If that's not the case then the default mixer initialization db needs to be fixed. Reassigning to alsa-utils.
Comment 8 Jaroslav Kysela 2009-04-03 13:03:44 EDT
It's not alsa-utils bug. The initialization code does not know if the system has connected analog or digital speakers.
Comment 9 Vlad 2009-04-03 13:30:50 EDT
I think, that analog is more likely. May be the best solution is to include this option in gnome-volume-control or pavucontrol?
Comment 10 Lennart Poettering 2009-04-03 13:48:56 EDT
Jarsolav, what's are 'digital speakers'? SPDIF? If that's the case, is this switch toggled when the device is opened via 'spdif:'? If so, PA should support this just fine via the profile selection in pavucontrol.
Comment 11 Jaroslav Kysela 2009-04-10 08:42:59 EDT
If I remember correctly, Audigy cards shares one jack with both S/PDIF and analog output.

And yes, we toggle this switch on when spdif device is used and off when the device is closed. It looks like that spdif PCM device was opened and then something crashed while profile change (ALSA PCM handle was not closed correctly - thus Analog/Digital switch value was not preserved).
Comment 12 Lennart Poettering 2009-04-10 10:56:10 EDT
Jaroslav. Maybe that control should be switched off when 'front:' or 'surround51:' or a similar device is opened?
Comment 13 Lennart Poettering 2009-04-13 11:31:09 EDT
Hmm, not sure what to do about this bug. Somehow I believe this somethin that should be fixed in ALSA, not in PA. PA has no clue about the meaning of the various ALSA controls. Hence assigning back.
Comment 14 Jaroslav Kysela 2009-04-14 03:17:29 EDT
Just a note for me: It seems that control value preserving should be implemented at kernel level (in the driver) to avoid exactly these cases when application crashes. We can eventually use some other mechanism like files on HDD or shared memory, but implementation will be more complicated that the kernel one.

Note for Lennart: We cannot touch this control outside spdif device, because if user have digital speakers, working output from front: device is expected.
Comment 15 Bug Zapper 2009-06-09 09:08:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Bug Zapper 2010-04-27 09:27:44 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2010-06-28 07:40:19 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.