Bug 493738 - can't send to newgroup
can't send to newgroup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 17:33 EDT by sean
Modified: 2009-04-08 11:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 11:47:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
T'bird Account setting for gmane (106.58 KB, image/png)
2009-04-05 15:49 EDT, sean
no flags Details
T'bird server setting for gmane (115.19 KB, image/png)
2009-04-05 15:50 EDT, sean
no flags Details
error message on attempted post (250.23 KB, image/png)
2009-04-05 18:16 EDT, sean
no flags Details

  None (edit)
Description sean 2009-04-02 17:33:40 EDT
Description of problem:
When I try to send to a newsgroup ( or reply) I get the "send message error", "please verify settings....". But email using the _same_ smtp server works. I have two smtp servers - 1and1 and gmail - set up. Both work for email, neither works for newsgroups.

This setup worked in T'bird 2.

Version-Release number of selected component (if applicable):
thunderbird-3.0-2.1.beta2.fc11.i586

How reproducible:
gmane newsgroup. Try to send message to fedora testers.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2009-04-03 11:54:39 EDT
a) cannot reproduce here ... both email and newsgroups just work
b) there is no connection between SMTP server and newsgroups ... do you mean email lists?

Please, give some more details about your system, configuration of both system and network, so that I can reproduce it here. Otherwise we cannot do much about this.
Comment 2 sean 2009-04-05 15:49:48 EDT
Created attachment 338252 [details]
T'bird Account setting for gmane
Comment 3 sean 2009-04-05 15:50:54 EDT
Created attachment 338253 [details]
T'bird server setting for gmane
Comment 4 sean 2009-04-05 16:03:33 EDT
I'm running rawhide i386/i586 updated to today on an intel hp laptop. Pretty generic.

It's newsgroups, gmane. As you can see from the screenshot of the account setting, T'bird asks for an smtp server for newsgroups. Maybe it doesn't use it? In any event, the error message comes up immediately - no trying to connect. I've also attached the server setting. I've checked and it seems correct. I'm pretty sure it's the same as what I used in 2.0.

I've tried to downgrade to 2.0, but F10 rpm won't install. So I tried to rebuild the most recent koji build - thunderbird-2.0.0.21-1.fc10.src.rpm. That died building nsAppRunner:

 nsAppRunner.cpp:1373:6: error: #elif with no expression

which I assume is a gcc-4.4 'ism.
Comment 5 sean 2009-04-05 18:16:04 EDT
Created attachment 338265 [details]
error message on attempted post

This is a screen shot of an attempted posting to fedora.testers. As I mentioned, this error comes up immediately on clicking Send.
Comment 6 Matěj Cepl 2009-04-08 11:47:12 EDT
To gmane through my local news server (i.e., there is no problem with TB talking NNTP) http://article.gmane.org/gmane.test/5172
and sent directly (i.e., TB sends to news.gmane.org)
http://article.gmane.org/gmane.test/5173

Closing as WORKSFORME and please let me know whether you have some ideas, how could I reproduce it here.

Note You need to log in before you can comment on or make changes to this bug.