Bug 493743 - F11 - cannot start VM install with ISO as media
F11 - cannot start VM install with ISO as media
Status: CLOSED DUPLICATE of bug 493692
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 17:58 EDT by Joel
Modified: 2009-04-03 06:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 06:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel 2009-04-02 17:58:37 EDT
Description of problem:
On a fresh Fedora 11 install (updated April 2nd 4:30pm EST).

When trying to create a VM using virt-manager that uses an ISO file as the media source, it fails with:

libvirtError: internal error unable to start guest: qemu: could not open disk image /root/RHEL5.3-Server-i386-DVD.iso


Version-Release number of selected component (if applicable):
virt-manager-0.7.0-2.fc11.i586

How reproducible:
Every single time

Steps to Reproduce:
1. Start virt-manager and hit the "new" button to create a new VM, give it a name, and select "Local install media"...hit "Forward".
2. Use ISO image, and point to the path of an ISO on the filesystem, OS Type: Linux, Version: Red Hat Enterprise Linux 5 ... hit "Forward"
3. Memory: 256, CPUs: 1 ... hit "Forward"
4. Check "Enable storage for this virtual machine", Create a 4GB disk image, and check "Allocate entire disk now" ... hit "Forward"
5. At the final screen, hit "Finish"
6. Wait a few moments, and it will fail

Actual results:

Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: qemu: could not open disk image /root/RHEL5.3-Server-i386-DVD.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1495, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 973, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: qemu: could not open disk image /root/RHEL5.3-Server-i386-DVD.iso

'
  


Expected results:
A new window showing the Bochs BIOS screen, followed by the CDROMs boot screen.

Additional info:

If you avoid 'virt-manager' and work with 'qemu-kvm' directly, it launches the VM as expected when you run the following:

qemu-img create -f qcow rhel5.3.img 4G
qemu-kvm -boot d -cdrom /root/RHEL5.3-Server-i386-DVD.iso -hda ./rhel5.3.img
Comment 1 Mark McLoughlin 2009-04-03 06:15:35 EDT
Are there any SELinux errors? Does temporarily setting SELinux to permissive mode fix the problem?
Comment 2 Mark McLoughlin 2009-04-03 06:21:54 EDT
Okay, bug #493692 looks like the same problem - please provide more info there. Thanks

*** This bug has been marked as a duplicate of bug 493692 ***

Note You need to log in before you can comment on or make changes to this bug.