Bug 493760 - setroubleshoot avc's
setroubleshoot avc's
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 20:31 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 08:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2009-04-02 20:31:39 EDT
This fail is almost comedic..

type=AVC msg=audit(1238718282.630:12255): avc:  denied  { execmem } for  pid=8305 comm="setroubleshootd" scontext=system_u:system_r:setroubleshootd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:setroubleshootd_t:s0-s0:c0.c1023 tclass=process

This AVC triggers setroubleshoot to then start up, and oops.. Another AVC, which causes...
Comment 1 Dave Jones 2009-04-02 20:55:21 EDT
there's a gazillion msgs in dmesg like ..

setroubleshootd[8604] general protection ip:7f024265790d sp:7fff4ab85c00 error:0 in libpython2.6.so.1.0[7f02425be000+169000]

which is likely related.
Comment 2 Dave Jones 2009-04-04 17:05:17 EDT
haven't seen this happen since I did a complete relabel.

red herring?
Comment 3 Daniel Walsh 2009-04-06 08:47:53 EDT
There were other problems causing the libpython crash (libselinux) and the execmem (nss).

So both should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.