Bug 493766 - setroubleshootd constantly crashing
setroubleshootd constantly crashing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 21:16 EDT by David Cantrell
Modified: 2009-04-03 09:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 09:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Extract of /var/log/messages showing setroubleshootd failures (6.40 KB, text/plain)
2009-04-03 09:34 EDT, Ewan Mac Mahon
no flags Details

  None (edit)
Description David Cantrell 2009-04-02 21:16:46 EDT
I'm seeing this over and over via dmesg:

__ratelimit: 11 callbacks suppressed
setroubleshootd[8764] general protection ip:3f8229990d sp:7ffff24ec570 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8766] general protection ip:3f8229990d sp:7fff45eddf60 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8768] general protection ip:3f8229990d sp:7ffff33353b0 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8770] general protection ip:3f8229990d sp:7fffa0fce050 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8772] general protection ip:3f8229990d sp:7fff9f1b2ca0 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8774] general protection ip:3f8229990d sp:7fff910a1120 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8776] general protection ip:3f8229990d sp:7ffff2b88c00 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8778] general protection ip:3f8229990d sp:7fffdee53ed0 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8780] general protection ip:3f8229990d sp:7fffda0360b0 error:0 in libpython2.6.so.1.0[3f82200000+169000]
setroubleshootd[8786] general protection ip:3f8229990d sp:7fff2548f510 error:0 in libpython2.6.so.1.0[3f82200000+169000]

The CPU is pegged at about 1.50 as setroubleshootd keeps getting respawned.  This occurred after I updated to rawhide for 02-Apr-2009.

Let me know if there's any other debugging info I can provide.
Comment 1 Ewan Mac Mahon 2009-04-03 09:33:32 EDT
I'm seeing something similar on current rawhide but with slightly different symptoms, so I'm not sure if it's the same, related, or just a random coincidence.

I don't see the errors in dmesg, but I do get entries in messages (extract attached) suggesting that setroubleshootd is itself getting AVC denials, and there's a lot of CPU usage. Stopping auditd breaks the cycle, and it can then be restarted without the problem immediately starting again.

I suspect it may start again on the next AVC denial, but I'm not sure if there's a good way to deliberately trigger one.
Comment 2 Ewan Mac Mahon 2009-04-03 09:34:47 EDT
Created attachment 338038 [details]
Extract of /var/log/messages showing setroubleshootd failures
Comment 3 Daniel Walsh 2009-04-03 09:57:09 EDT
The AVC messages about setroubleshoot are caused by a bug in the nss package, which should be fixed in todays rawhide.

The crashing of setroubleshoot is fixed by the update of todays libselinux.

setroubleshoot going nuts starting and stopping should be fixed by an update to its setroubleshoot package in tomorrows rawhide.

 nss                             x86_64 3.12.2.99.3-5.fc11      rawhide   1.0 M
 libselinux                      i586   2.0.79-5.fc11           rawhide   105 k

setroubleshoot-2.1.7-1.fc11

Note You need to log in before you can comment on or make changes to this bug.