Bug 493776 - mute button not working
mute button not working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-02 23:01 EDT by Matthew Savukinas
Modified: 2009-05-26 09:14 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 09:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Savukinas 2009-04-02 23:01:51 EDT
Description of problem:Mute button doesnt work , Dell 630 ,not sure what catagory to put this under . But I have fedora 11 beta with kde4.2 installed and the volume up and down buttons work but the mute button doesnt . It worke in fedora 10 with the same software installed . The only thing it does now is bring up the volume window . 


Version-Release number of selected component (if applicable):fedora 11 beta 


How reproducible:


Steps to Reproduce:
1.press mute button 
2. ???
3. doesnt mute speakers 
  
Actual results:
brings up volume window 

Expected results:mute the speakers 


Additional info: My laptop doesnt have a network connection at this time but any needed information or output can be provided in the morning and also provide anything else thats needed in the morning
Comment 1 Matthew Savukinas 2009-04-02 23:02:55 EDT
if you need any output or need me to do anything please email me with the commands / questions / ect 
Thank you
Comment 2 Kevin Kofler 2009-04-03 01:19:04 EDT
This is yet again the "multimedia keys don't work" issue. Don't we have several other bugs filed for this?

(Setting needinfo on our triager.)
Comment 3 Steven M. Parrish 2009-04-03 07:33:16 EDT
We do have several bugs reported where there is an issue with multimedia keys.  Will create a tracking bug for them
Comment 4 Matthew Savukinas 2009-04-03 09:29:32 EDT
this can be closed then , Sorry i must have been searching for the wrong thing when I checked fedora . If there is any output or anything I can provide or test please let me know .
Comment 5 Matthew Savukinas 2009-04-03 09:33:42 EDT
I have searched multimedia keys not working , multimedia , multimedia keys and function keys and couldnt find any other bug for this , if someone has time can you let me know one of the other bug reports or tracking bug id's . I would like to contribute and help out in anyway that I can .
Comment 6 Charles R. Anderson 2009-04-27 10:12:53 EDT
I'm seeing exactly the same thing:  volume up and volume down buttons work fine, but the mute button doesn't work.  Nothing appears on the screen when I press the mute button.  This is on a Lenovo T61.
Comment 7 Charles R. Anderson 2009-04-27 10:15:30 EDT
xev shows this when I press the "mute" button:

KeymapNotify event, serial 30, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   


followed by this when I release the "mute" button:

KeyRelease event, serial 30, synthetic NO, window 0x4800001,
    root 0xfa, subw 0x0, time 84174855, (98,159), root:(104,272),
    state 0x0, keycode 121 (keysym 0x1008ff12, XF86AudioMute), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 8 Steven M. Parrish 2009-04-27 20:04:52 EDT
There have been several bugs in this regard on F9, F10 and now Rawhide.  My own multimedia keys did not work under F9, but now do on both F10 and rawhide.  Not sure what if anything we here in Fedora KDE land can do about this issue.  At this time your best bet would be to file bugs upstream giving the devs as much info as possible.
Comment 9 Steven M. Parrish 2009-05-26 09:14:53 EDT
Going to close this as UPSTREAM.  Since there is little the KDE-SIG can do
about this and other multimedia/laptop button issues we have to wait for
upstream to address this.

Note You need to log in before you can comment on or make changes to this bug.