Bug 493784 - NetworkManager: erratic handling of WPA password upon suspend/resume
NetworkManager: erratic handling of WPA password upon suspend/resume
Status: CLOSED DUPLICATE of bug 477964
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 00:31 EDT by Jean-Philippe
Modified: 2009-11-10 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 20:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Philippe 2009-04-03 00:31:55 EDT
Description of problem:
Whenever I suspend by closing the lid of my ASUS F9 laptop which uses the iwl3945 driver to connect 95% of the time, I'll never know if the password will be remembered on resume or will pop asking for remembered password & to click "connect".

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0
Fedora10 kernel 2.6.27.9-159.fc10.x86_64
iwl3945-firmware-15.28.2.8
gnome-keyring-2.24.1

How reproducible:
Persistent (while erratic, indeed) under x86_64 version of F10 install.

Steps to Reproduce:
1. Connect with WiFi
2. Close the lid 
3. Open it and resume: one time out of 3 it pops for password.
  
Actual results:
Annoying pop-up to click on, slower access to network, confuses the user on the validity of settings

Expected results:
NetworkManager quietly reconnects upon resume.


Additional info:
May be related to bugs in password management from the gnome desktop, I don't know but I read somewhere that it was one of the reason we have no autologin in gnome anymore. (I am NOT using any autologin hacks, that's the source of my knowledge, I tried it with Fedora9 and it killed the ability of NetworkManager to quietly send the password upon boot/login.)
Comment 1 Jean-Philippe 2009-04-03 00:36:03 EDT
The above issue is not related, and behaves independently, from 493785:
NetworkManager: erratic handling of "Enable Networking" upon suspend/resume
Comment 2 Niels Haase 2009-04-09 21:15:04 EDT
Thanks for filling this bug.

can you please provide the /var/log/messages after you open the lid and the NM pop-ups appear?

Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Jean-Philippe 2009-04-30 04:09:04 EDT
Sorry for the delay - @ 14:04 I closed the lid, and re-opened the thing at 14:59 and it asked me my wpa pass instead wherever it should have send the one stored in config

[Yes, it's all towards the same router, indeed, I didn't change/move, switch network anything]


[root@F9E ~]# less /var/log/messages | grep 'Apr 30 14'
Apr 30 14:04:52 localhost NetworkManager: <info>  Sleeping...
Apr 30 14:04:52 localhost NetworkManager: <info>  (wlan0): now unmanaged
Apr 30 14:04:52 localhost NetworkManager: <info>  (wlan0): device state change: 8 -> 1
Apr 30 14:04:52 localhost NetworkManager: <info>  (wlan0): deactivating device (reason: 37).
Apr 30 14:04:52 localhost NetworkManager: <WARN>  check_one_route(): (wlan0) error -34 returned from rtnl_route_del(): Sucess#012
Apr 30 14:04:52 localhost avahi-daemon[2953]: Withdrawing address record for 192.168.1.99 on wlan0.
Apr 30 14:04:52 localhost avahi-daemon[2953]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.99.
Apr 30 14:04:52 localhost NetworkManager: <info>  (wlan0): cleaning up...
Apr 30 14:04:52 localhost avahi-daemon[2953]: Interface wlan0.IPv4 no longer relevant for mDNS.
Apr 30 14:04:52 localhost NetworkManager: <info>  (wlan0): taking down device.
Apr 30 14:04:52 localhost kernel: iwl3945 0000:02:00.0: PCI INT A disabled
Apr 30 14:04:52 localhost avahi-daemon[2953]: Withdrawing address record for fe80::21c:bfff:fec7:1cd0 on wlan0.
Apr 30 14:04:52 localhost NetworkManager: <info>  (eth0): now unmanaged
Apr 30 14:04:52 localhost NetworkManager: <info>  (eth0): device state change: 2 -> 1
Apr 30 14:04:52 localhost NetworkManager: <info>  (eth0): cleaning up...
Apr 30 14:04:52 localhost NetworkManager: <info>  (eth0): taking down device.
Apr 30 14:04:56 localhost kernel: PM: Syncing filesystems ... done.
Apr 30 14:59:56 localhost acpid: client has disconnected
Apr 30 14:59:56 localhost kernel: Freezing user space processes ... (elapsed 0.00 seconds) done.
Apr 30 14:59:56 localhost kernel: Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
Apr 30 14:59:56 localhost kernel: Suspending console(s) (use no_console_suspend to debug)
Apr 30 14:59:56 localhost kernel: pci 0000:00:02.0: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek USB2.0 Camera disconnected
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek USB2.0 Camera release resources video device /dev/video0
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] Synchronizing SCSI cache
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] Stopping disk
Apr 30 14:59:56 localhost kernel: r8169 0000:01:00.0: PME# enabled
Apr 30 14:59:56 localhost kernel: r8169 0000:01:00.0: wake-up capability enabled by ACPI
Apr 30 14:59:56 localhost kernel: ahci 0000:00:1f.2: PCI INT B disabled
Apr 30 14:59:56 localhost kernel: ata_piix 0000:00:1f.1: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: ehci_hcd 0000:00:1d.7: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.2: PCI INT C disabled
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.1: PCI INT B disabled
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.0: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: HDA Intel 0000:00:1b.0: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: ehci_hcd 0000:00:1a.7: PCI INT C disabled
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1a.1: PCI INT B disabled
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1a.0: PCI INT A disabled
Apr 30 14:59:56 localhost kernel: ACPI: Preparing to enter system sleep state S3
Apr 30 14:59:56 localhost kernel: Disabling non-boot CPUs ...
Apr 30 14:59:56 localhost kernel: CPU 1 is now offline
Apr 30 14:59:56 localhost kernel: SMP alternatives: switching to UP code
Apr 30 14:59:56 localhost kernel: CPU1 is down
Apr 30 14:59:56 localhost kernel: Extended CMOS year: 2000
Apr 30 14:59:56 localhost kernel: x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
Apr 30 14:59:56 localhost kernel: Extended CMOS year: 2000
Apr 30 14:59:56 localhost kernel: Enabling non-boot CPUs ...
Apr 30 14:59:56 localhost kernel: SMP alternatives: switching to SMP code
Apr 30 14:59:56 localhost kernel: Booting processor 1/1 ip 6000
Apr 30 14:59:56 localhost kernel: Initializing CPU#1
Apr 30 14:59:56 localhost kernel: Calibrating delay using timer specific routine.. 4189.54 BogoMIPS (lpj=2094771)
Apr 30 14:59:56 localhost kernel: CPU: L1 I cache: 32K, L1 D cache: 32K
Apr 30 14:59:56 localhost kernel: CPU: L2 cache: 3072K
Apr 30 14:59:56 localhost kernel: CPU 1/1 -> Node 0
Apr 30 14:59:56 localhost kernel: CPU: Physical Processor ID: 0
Apr 30 14:59:56 localhost kernel: CPU: Processor Core ID: 1
Apr 30 14:59:56 localhost kernel: x86 PAT enabled: cpu 1, old 0x7040600070406, new 0x7010600070106
Apr 30 14:59:56 localhost kernel: CPU1: Intel(R) Core(TM)2 Duo CPU     T8100  @ 2.10GHz stepping 06
Apr 30 14:59:56 localhost kernel: CPU1 is up
Apr 30 14:59:56 localhost kernel: ACPI: Waking up from system sleep state S3
Apr 30 14:59:56 localhost kernel: ACPI: EC: non-query interrupt received, switching to interrupt mode
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1a.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Apr 30 14:59:56 localhost kernel: usb usb3: root hub lost power or was reset
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1a.1: PCI INT B -> GSI 21 (level, low) -> IRQ 21
Apr 30 14:59:56 localhost kernel: usb usb4: root hub lost power or was reset
Apr 30 14:59:56 localhost kernel: ehci_hcd 0000:00:1a.7: PCI INT C -> GSI 18 (level, low) -> IRQ 18
Apr 30 14:59:56 localhost kernel: HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
Apr 30 14:59:56 localhost kernel: usb usb5: root hub lost power or was reset
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
Apr 30 14:59:56 localhost kernel: usb usb6: root hub lost power or was reset
Apr 30 14:59:56 localhost kernel: uhci_hcd 0000:00:1d.2: PCI INT C -> GSI 18 (level, low) -> IRQ 18
Apr 30 14:59:56 localhost kernel: usb usb7: root hub lost power or was reset
Apr 30 14:59:56 localhost kernel: ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
Apr 30 14:59:56 localhost kernel: ata_piix 0000:00:1f.1: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Apr 30 14:59:56 localhost kernel: ahci 0000:00:1f.2: PCI INT B -> GSI 20 (level, low) -> IRQ 20
Apr 30 14:59:56 localhost kernel: r8169 0000:01:00.0: wake-up capability disabled by ACPI
Apr 30 14:59:56 localhost kernel: r8169 0000:01:00.0: PME# disabled
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] Starting disk
Apr 30 14:59:56 localhost kernel: ata4.00: ACPI cmd ef/03:42:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata4.00: ACPI cmd ef/03:0c:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata4.00: configured for UDMA/33
Apr 30 14:59:56 localhost kernel: ata3: SATA link down (SStatus 0 SControl 300)
Apr 30 14:59:56 localhost kernel: ata2: SATA link down (SStatus 0 SControl 300)
Apr 30 14:59:56 localhost kernel: ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Apr 30 14:59:56 localhost kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata1.00: ACPI cmd f5/00:00:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata1.00: ACPI cmd ef/10:03:00:00:00:a0 filtered out
Apr 30 14:59:56 localhost kernel: ata1.00: configured for UDMA/133
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] Write Protect is off
Apr 30 14:59:56 localhost kernel: sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Apr 30 14:59:56 localhost kernel: pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek USB2.0 - STK-1135 based webcam found.
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek AVStream USB2.0 1.3M WebCam - Product ID 0x6A33.
Apr 30 14:59:56 localhost kernel: stk11xx: Release: 0005
Apr 30 14:59:56 localhost kernel: stk11xx: Number of interfaces : 1
Apr 30 14:59:56 localhost kernel: stk11xx: Initialize USB2.0 Syntek Camera
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek USB2.0 Camera is ready
Apr 30 14:59:56 localhost kernel: stk11xx: Syntek USB2.0 Camera is now controlling video device /dev/video0
Apr 30 14:59:56 localhost kernel: Restarting tasks ... done.
Apr 30 14:59:58 localhost acpid: client connected from 3149[0:0]
[root@F9E ~]#
Comment 4 Dan Williams 2009-10-16 17:48:31 EDT
Usually this happens because wpa_supplicant' can't connect to the AP, which is sometimes due to driver problems.  Can you run 'nm-tool' and report waht it says after you open the lid?
Comment 5 Jean-Philippe 2009-10-26 08:48:12 EDT
sorry for the delay again

output, before closing lid:
-{*~*}- ~ nm-tool

NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        00:1F:C6:D9:87:3D

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [Auto 54pasteur] ----------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl3945
  State:             connected
  Default:           yes
  HW Address:        00:1C:BF:C7:1C:D0

  Capabilities:
    Speed:           24 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *54pasteur:      Infra, 00:23:69:A4:1D:B9, Freq 2437 MHz, Rate 54 Mb/s, Strength 76 WPA2
    ClickNet:        Infra, 00:19:BE:00:0A:60, Freq 2452 MHz, Rate 54 Mb/s, Strength 38
    51pasteur:       Infra, 00:12:17:17:14:DC, Freq 2462 MHz, Rate 11 Mb/s, Strength 54 WPA

  IPv4 Settings:
    Address:         192.168.2.201
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             208.67.222.222
    DNS:             208.67.220.220


LId closed, reopened, NetworkManager has disabled itself automatically :(

-{*~*}- ~ nm-tool

NetworkManager Tool

State: asleep

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unmanaged
  Default:           no
  HW Address:        00:1F:C6:D9:87:3D

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl3945
  State:             unmanaged
  Default:           no
  HW Address:        00:1C:BF:C7:1C:D0

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 


Enabling NM, autoconnect to my main router:

-{*~*}- ~ nm-tool

NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        00:1F:C6:D9:87:3D

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0  [Auto 54pasteur] ----------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwl3945
  State:             connected
  Default:           yes
  HW Address:        00:1C:BF:C7:1C:D0

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *54pasteur:      Infra, 00:23:69:A4:1D:B9, Freq 2437 MHz, Rate 54 Mb/s, Strength 72 WPA2
    ClickNet:        Infra, 00:19:BE:00:0A:60, Freq 2452 MHz, Rate 54 Mb/s, Strength 35
    51pasteur:       Infra, 00:12:17:17:14:DC, Freq 2462 MHz, Rate 11 Mb/s, Strength 59 WPA

  IPv4 Settings:
    Address:         192.168.2.201
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             208.67.222.222
    DNS:             208.67.220.220
Comment 6 Dan Williams 2009-11-10 20:14:28 EST
That actually matches the semantics of bug #477964.  If NM is still "asleep" after the laptop resumes, then it's the D-Bus bug with short-lived processes that bug #477964 describes.

*** This bug has been marked as a duplicate of bug 477964 ***

Note You need to log in before you can comment on or make changes to this bug.