Bug 493790 - Output to Intel 82801H no longer works
Output to Intel 82801H no longer works
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 01:15 EDT by Dimi Paun
Modified: 2009-04-30 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 20:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.sh --no-upload (37.53 KB, text/plain)
2009-04-03 20:31 EDT, Dimi Paun
no flags Details

  None (edit)
Description Dimi Paun 2009-04-03 01:15:15 EDT
Description of problem:
I have upgraded from F8 to F11 Beta, and the sound stopped working.
It used to work just fine in F8. I do get sound on the USB headphones,
but nothing on the speakers.

Version-Release number of selected component (if applicable):

[root@dimi ~]# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

[root@dimi ~]# rpm -q pulseaudio
pulseaudio-0.9.15-8.test7.fc11.i586

[root@dimi ~]# rpm -qa | grep alsa
alsa-utils-1.0.19-4.fc11.i586
alsa-tools-firmware-1.0.19-3.fc11.i586
alsa-lib-devel-1.0.19-3.fc11.i586
alsa-tools-1.0.19-3.fc11.i586
alsa-firmware-1.0.19-4.fc11.noarch
alsa-plugins-pulseaudio-1.0.18-3.fc11.i586
alsa-plugins-oss-1.0.18-3.fc11.i586
alsa-oss-1.0.17-3.fc11.i586
alsa-lib-1.0.19-3.fc11.i586
alsa-oss-libs-1.0.17-3.fc11.i586

[root@dimi ~]# uname -a
Linux dimi.lattica.com 2.6.29.1-37.rc1.fc11.i686.PAE #1 SMP Wed Apr 1 08:57:05 EDT 2009 i686 i686 i386 GNU/Linux

How reproducible:
Always.
Comment 1 Lennart Poettering 2009-04-03 11:46:04 EDT
Please be more elaborate. What do you my "stopped working"? Do the applications appear to play music but you cannot hear anything? Most likely this is a mixer initialization issue then which can be fixed by playing around with "alsamixer -c0".
Comment 2 Dimi Paun 2009-04-03 12:09:03 EDT
Yes, this is exactly right -- applications appear to play music but I can not hear anything. This used to work just fine in F8 (except for the occasional PA crash). 

I've tried "alsamixer" and indeed it worked. However, how should I know about this? Before I used to double click on the volume control (and as confusing as that thing used to be), I could do it from there? Not anymore. 

I think a regular user would have _zero_ chance of figuring this out. I am an experienced user, tried Googling it, etc for 1-2h, to no avail. Why would be the sound turned off by default? Why do I even have to mess around with alsamixer -c0?

This has been a problem as far as I can remember, the only difference now is that there's no easy way to fix it (graphically). Can this be fixed properly?
Comment 3 Lennart Poettering 2009-04-03 12:32:11 EDT
It's a bug in the default mixer initialization of ALSA. Reassigning.

ALSA maintains a databse of default mixer initializations for different hardware. You sound card needs to be added there.
Comment 4 Jaroslav Kysela 2009-04-03 12:39:45 EDT
Please, attach output from 'alsa-info.sh --no-upload' script.
Comment 5 Jaroslav Kysela 2009-04-03 12:41:17 EDT
And elaborate which mixer controls should be initialized for your hardware with 'alsamixer -c0'. Thanks.
Comment 6 Dimi Paun 2009-04-03 20:31:10 EDT
Created attachment 338137 [details]
alsa-info.sh --no-upload
Comment 7 Dimi Paun 2009-04-03 20:34:55 EDT
I can't quite remember which ones I had to change, but 
these are the controls that I see for Playback:

Master 
Headphon    
PCM     
Front    
Front Mi 
Front Mi 
Surround   
Center    
LFE       
Side     
Line      
CD       
Mic    
Mic Boos   
IEC958  
IEC958 D 
IEC958 P    
Mono   
Analog M
Comment 8 Adam Williamson 2009-04-27 19:38:57 EDT
Dimi: try this, as root:

cp /etc/asound.state /etc/asound.state.bak
alsactl restore

that should reset all volumes to default, which should hopefully make the problem exist again. then you can fix it again, this time taking a note of which channels you need to adjust (and how) to make things work. thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2009-04-27 19:39:20 EDT
(or just 'alsactl init' should do it in fact)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Dimi Paun 2009-04-27 21:04:21 EDT
Hm, first result:

[root@dimi ~]# cp /etc/asound.state /etc/asound.state.bak
[root@dimi ~]# alsactl init
Unknown hardware: "HDA-Intel" "Analog Devices AD1988B" "HDA:11d4198b,104381f6,00100200" "" ""
Hardware is initialized using a guess method
Comment 11 Dimi Paun 2009-04-27 21:11:37 EDT
I can see after the init that 
   PCM is at 61
 Front is at 67
Master is at 64

AFAICT, Master can be controlled through the Volume Control, but the others should be at 100, no?

Also, after the init I get no more sound. I tried killing pulseaudio, but still no sound :(
Comment 12 Adam Williamson 2009-04-28 19:44:49 EDT
yes. er, maybe i'm not explaining very well.

I expected the problem would show up again after doing 'alsamixer init'. That's what I *wanted* to happen :). The point being that you can then recreate the fix, and make a note of which channel you had to adjust to make things work. That will then let us know what the correct fix will be.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Dimi Paun 2009-04-30 16:00:08 EDT
No, I understood -- it's just that after the init, I couldn't restore sound, no matter what I did.

However, I just updated to latest, rebooted, and the sound (and ALSA settings) where OK, so I guess it has been fixed.
Comment 14 Adam Williamson 2009-04-30 19:30:28 EDT
so, um, just to get a handle on this - if you now do 'alsamixer init' again, sound is still fine? or you have to adjust something subsequent to the 'alsamixer init' to get sound?
Comment 15 Dimi Paun 2009-04-30 19:40:06 EDT
This seems to be OK now, 'alsactl init' doesn't seem to mess with the sound.

However, now I get this:

[root@dimi ~]# alsactl init
Unknown hardware: "USB-Audio" "USB Mixer" "USB047f:0ca1" "" ""
Hardware is initialized using a guess method

Here is my ALSA information:
    http://www.alsa-project.org/db/?f=4e671874d8c62ad8525415bed16ba06b307cb08e
Comment 16 Adam Williamson 2009-04-30 20:55:41 EDT
as long as you get working sound after 'alsactl init', all is good, the default values are good, and there's no bug. "Hardware is initialized using a guess method" isn't a problem, it just means there's no explicit configuration in the database for that device so it's using the defaults. Which are obviously fine.

Note You need to log in before you can comment on or make changes to this bug.