Bug 493801 - sugar desktop fails to start on guest rawhide-i386
sugar desktop fails to start on guest rawhide-i386
Status: CLOSED DUPLICATE of bug 492838
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-04-03 03:24 EDT by Jens Petersen
Modified: 2009-05-11 11:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 20:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
~/.sugar/default/logs/shell.log (688 bytes, text/plain)
2009-04-06 04:20 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2009-04-03 03:24:52 EDT
Description of problem:
Sugar desktop fails to start for me in current rawhide.

How reproducible:
every time

Steps to Reproduce:
1. install rawhide
2. yum install @sugar-desktop
3. reboot and try to start sugar desktop
  
Actual results:
returns to gdm login (after choose name and color)

Expected results:
Sugar desktop running
Comment 1 Simon Schampijer 2009-04-03 14:22:17 EDT
Thanks for the report. 

Can you install 'sugar-emulator' and run that in GNOME or KDE (this emulates sugar)? That would be helpful to see why we are failing. Another option is to grab the logs in ~/.sugar/default/logs/shell.log 

I am here on rawhide too - but am changing many things - so might be different.

And the output of 'rpm -q sugar' might be helpful as well.
Comment 2 Jens Petersen 2009-04-06 04:14:03 EDT
(In reply to comment #1)
> Can you install 'sugar-emulator' and run that in GNOME or KDE (this emulates
> sugar)? That would be helpful to see why we are failing. 

sugar-emulator runs - though I only have black screen with pointer.

> And the output of 'rpm -q sugar' might be helpful as well.  

sugar-0.84.1-4.20090401git4232758da5.fc11
Comment 3 Jens Petersen 2009-04-06 04:20:57 EDT
Created attachment 338296 [details]
~/.sugar/default/logs/shell.log

Here is the shell.log output.

However I am wondering if this is related to bug 492838.

I only have a kvm guest to test on currently.
Comment 4 Simon Schampijer 2009-04-06 04:27:47 EDT
Interesting. At least the error message is the same then the one in the other traceback https://bugzilla.redhat.com/attachment.cgi?id=337199

Thanks verry much for the logs
Comment 5 Fedora Admin XMLRPC Client 2009-04-06 16:39:54 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Jens Petersen 2009-04-15 05:28:45 EDT
sugar still not starting when I retested in yesterdau's rawhide.
Comment 7 Simon Schampijer 2009-05-06 07:42:04 EDT
Jens, there was progress on #492838 - can you tell if this bug is dependent on it?
Comment 8 Jens Petersen 2009-05-06 19:31:07 EDT
Actually there is no progress on bug 492838 yet AFAIK, but sugar-desktop runs for me on my current rawhide install. :)
Comment 9 Jens Petersen 2009-05-06 20:14:16 EDT
However it still crashes on rawhide-i386 on kvm but not raw-x86_64 on kvm so yes I think this is a duplicate of bug 492838.

*** This bug has been marked as a duplicate of bug 492838 ***
Comment 10 Simon Schampijer 2009-05-07 06:32:20 EDT
Ok, that is some progress :) Jens, thanks for following up on this.

Note You need to log in before you can comment on or make changes to this bug.