Bug 493807 - virt-install: --vnclisten=<ip> option would be nice
virt-install: --vnclisten=<ip> option would be nice
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virtinst (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 04:07 EDT by Guido Günther
Modified: 2010-03-16 13:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 16:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 521044 None None None Never

  None (edit)
Description Guido Günther 2009-04-03 04:07:17 EDT
'virt-install --vnc' only opens by default a port on 127.0.0.1 and the
VM can't be remotely accessed through the VNC server.

It would be nice to add an option called "--vnclisten=<address>" to
virt-install like the actual "--vncport=VNCPORT".

This came in via the Debian BTS:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=521044
Comment 1 Daniel Berrange 2009-04-03 05:28:54 EDT
For the VNC listen address, most people find it more convenient to set this up system wide, so all VMs listen on the public address. You typically need to setup security credentials for the server in the system wide config already, so its easy to change the default listen address at the same time. On Xen this is /etc/xen/xend-config.sxp, and for QEMU this is /etc/libvirt/qemu.conf
Comment 2 Mark McLoughlin 2009-04-03 06:28:17 EDT
Looks like this is meant for upstream virtinst bugzilla
Comment 3 Guido Günther 2009-04-03 07:35:07 EDT
Then the manpage should be fixed/expaned?

Report bugs to the mailing list "http://www.redhat.com/mailman/listinfo/et-mgmt-tools" or directly to BugZilla "http://bugzilla.redhat.com/bugzilla/" against the "Fedora" product, and the "python-virtinst" component.
Comment 4 Cole Robinson 2009-05-07 16:27:00 EDT
There is certainly value in being able to specify this per-VM: we already expose a similar knob in virt-manager.

I've pushed this option upstream (though now I need to tweak the manpage to specify the default isn't necessarily 127.0.0.1):

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/78e590ca02ea
Comment 5 Guido Günther 2009-05-08 02:38:33 EDT
Awesome. Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.