Bug 493837 - S-c-tools cleanup: inputs checking
S-c-tools cleanup: inputs checking
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 493606
  Show dependency treegraph
 
Reported: 2009-04-03 05:59 EDT by Roman Rakus
Modified: 2016-06-10 05:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: system-config-network-1.5.99.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-10 05:55:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch that adds checking for valid IP addresses (6.32 KB, patch)
2009-08-12 05:13 EDT, Radek Novacek
no flags Details | Diff

  None (edit)
Description Roman Rakus 2009-04-03 05:59:24 EDT
Description of problem:
Every input should be tested and/or filtered.

How reproducible:
sane IP address input - sometimes every input is allowed (like "asasgdh"), sometimes dot style IP address but not correct (10.0.0.0.0)

Steps to Reproduce:
Do something without sense. For example fill IP address field with zywe

Actual results:
Tool will not notify user, that he write it wrong.

Expected results:
In some cases you can filter input (appropriate settings on widget). Notify user about his mistake and don't let tool to traceback.

Additional info:
You can set appropriate settings. You can use signal changed and/or focus-out for text fields.
Comment 1 Radek Novacek 2009-08-12 05:13:02 EDT
Created attachment 357130 [details]
Proposed patch that adds checking for valid IP addresses
Comment 2 Fedora Admin XMLRPC Client 2012-12-19 10:31:36 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Nils Philippsen 2016-06-10 05:55:02 EDT
The patch has long since been applied (version 1.5.99.1).

Note You need to log in before you can comment on or make changes to this bug.