Bug 493838 - S-c-tools cleanup: inputs checking
S-c-tools cleanup: inputs checking
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-nfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 493607
  Show dependency treegraph
 
Reported: 2009-04-03 05:59 EDT by Roman Rakus
Modified: 2016-08-11 07:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 07:27:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-03 05:59:35 EDT
Description of problem:
Every input should be tested and/or filtered.

How reproducible:
NFS Server Settings - incorrect input should be more verbose

Steps to Reproduce:
Do something without sense. For example fill IP address field with zywe

Actual results:
Tool will not notify user, that he write it wrong.

Expected results:
In some cases you can filter input (appropriate settings on widget). Notify user about his mistake and don't let tool to traceback.

Additional info:
You can set appropriate settings. You can use signal changed and/or focus-out for text fields.
Comment 2 Nils Philippsen 2016-08-11 07:27:05 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-nfs anymore, I won't likely find
the time to work on this ticket, so I'll close this bug now.

Note You need to log in before you can comment on or make changes to this bug.