Bug 493845 - S-c-tools cleanup: use frames without borders, using bold labels, spacing and indetation.
S-c-tools cleanup: use frames without borders, using bold labels, spacing and...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 493606
  Show dependency treegraph
 
Reported: 2009-04-03 06:01 EDT by Roman Rakus
Modified: 2016-06-10 05:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-10 05:50:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch that removes borders from frames (147.14 KB, patch)
2009-08-24 09:00 EDT, Radek Novacek
no flags Details | Diff

  None (edit)
Description Roman Rakus 2009-04-03 06:01:12 EDT
Description of problem:
Frames with a border around their perimeter have traditionally been used for denoting groups of related controls. This is advantageous because it physically seperates disimilar controls, and also avoids repitition of the frame's label in individual member control labels. Unfortunately, they add visual noise that can both make a window appear more complex than it really is, and reduce the ability to quickly scan window elements.

Rather than using bordered frames, use frames without borders, bold labels to make the categories stand out, and indented contents. This, combined with good layout and spacing, is usually a better alternative to bordered.

How reproducible:
Configure Net Settings, etc.

Steps to Reproduce:
1. invoke any dialog using frames

Actual results:
Frames with borders.

Expected results:
Frames without borders, using bold labels, spacing and indentation.

Additional info:
Look at GNOME Human Interface Guidelines 2.2 [1]

[1] http://library.gnome.org/devel/hig-book/stable/controls-frames.html.en
Comment 1 Harald Hoyer 2009-08-12 06:57:13 EDT
glade files are there and can be modified
Comment 2 Radek Novacek 2009-08-24 09:00:42 EDT
Created attachment 358454 [details]
Proposed patch that removes borders from frames
Comment 3 Fedora Admin XMLRPC Client 2012-12-19 10:31:41 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Nils Philippsen 2016-06-10 05:50:43 EDT
This component isn't actively developed anymore, so I'll close the bug.

Note You need to log in before you can comment on or make changes to this bug.