Bug 493850 - S-c-tools cleanup: bad spacings, alignment, layout
S-c-tools cleanup: bad spacings, alignment, layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-audit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 493593
  Show dependency treegraph
 
Reported: 2009-04-03 06:02 EDT by Roman Rakus
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 13:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-03 06:02:16 EDT
Description of problem
A clean, logical dialog layout helps the user to quickly understand what information is required from them. It's very important to have proper spacing between window borders, controls and separators (if used), controls alignment etc.

How reproducible:


Steps to Reproduce
1. invoke any dialog

Actual results
Incorrect controls spacing and alignment.

Expected results
Correct window/dialog layout.

Additional info
Look at GNOME Human Interface Guidelines 2.2 [1] [2] [3]

[1] http://library.gnome.org/devel/hig-book/stable/design-window.html.en 
[2] http://library.gnome.org/devel/hig-book/stable/windows-dialog.html.en 
[3] http://library.gnome.org/devel/hig-book/stable/windows-alert.html.en#alert-spacing
Comment 1 Miloslav Trmač 2009-07-29 13:56:24 EDT
Cna you provide specific instances, please?  The dialog layout attempts to follow the HIG.

I realize it's not looking as clean as other GNOME applications - as far as I can tell, that's caused by the large amount of information and its complexity (nesting) compared to other dialogs, not by ignoring the HIG.
Comment 2 Roman Rakus 2009-08-11 07:22:49 EDT
In 'main_app' window:
* Tabs are sticked to the window, there should be 12 pixels width border

In 'key_dialog' window:
* "Type" and "Severity" lables are centered
Comment 3 Miloslav Trmač 2009-09-15 13:18:39 EDT
Both fixed in rawhide system-config-audit-0.4.12.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.