Bug 493858 - S-c-tools cleanup: bad spacings, alignment, layout
S-c-tools cleanup: bad spacings, alignment, layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 493604
  Show dependency treegraph
 
Reported: 2009-04-03 06:03 EDT by Roman Rakus
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-11 00:51:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-03 06:03:41 EDT
Description of problem
A clean, logical dialog layout helps the user to quickly understand what information is required from them. It's very important to have proper spacing between window borders, controls and separators (if used), controls alignment etc.

How reproducible:


Steps to Reproduce
1. invoke any dialog

Actual results
Incorrect controls spacing and alignment.

Expected results
Correct window/dialog layout.

Additional info
Look at GNOME Human Interface Guidelines 2.2 [1] [2] [3]

[1] http://library.gnome.org/devel/hig-book/stable/design-window.html.en 
[2] http://library.gnome.org/devel/hig-book/stable/windows-dialog.html.en 
[3] http://library.gnome.org/devel/hig-book/stable/windows-alert.html.en#alert-spacing
Comment 1 Pravin Satpute 2009-04-24 06:21:00 EDT
"The flags allow the specification special dialog characteristics: make the dialog modal (gtk.DIALOG_MODAL) and destroy the dialog when the parent is destroyed (gtk.DIALOG_DESTROY_WITH_PARENT)."

I have used 'gtk.DIALOG_MODAL' in all gtk.MessageDialog.

Can you give some existing example, how it should be?
Comment 2 Roman Rakus 2009-04-27 06:51:57 EDT
The problem is in spacings. See http://library.gnome.org/devel/hig-book/stable/design-window.html.en
And dialog should be centered on parent.
Comment 3 Pravin Satpute 2009-07-13 06:49:37 EDT
done, these changes 
built for rawhide system-config-language-1.3.2-8

Note You need to log in before you can comment on or make changes to this bug.