Bug 49391 - (Cirrus 5480) on SGI 1200 with L440GX chipset broken
(Cirrus 5480) on SGI 1200 with L440GX chipset broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-18 19:51 EDT by Florin Andrei
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 17:21:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2001-07-18 19:51:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
I try to install Red Hat 7.1 on a SGI 1200 (motherboard L440GX+, dual
PIII). Xconfigurator works fine and detects my embedded video card (i think
it's CL GD5480), but when i start X the image is totally screwed up, the
windows are blurred and overlap each other... It's a mess.
If i install the X packages from RH 7.0 then it works (because 7.0 works
fine on SGI1200), but i have to --force some dependencies, and it's an ugly
solution anyway.

How reproducible:
Always

Steps to Reproduce:
1.Install RH7.1 on a system with L440GX motherboard
2.Configure X
3.Start X
	

Actual Results:  Like i said, the image is blurred and the windows are
screwed up.

Expected Results:  Instead, X Window should work fine, as it does with RH7.0

Additional info:
Comment 1 Mike A. Harris 2001-07-26 15:56:19 EDT
An experimental fix for the Cirrus driver for your hardware is in
our internal tree right now, and will be released in a week or so
in rawhide after some testing.

I will try to update this report at that time, and also backport the
fixes to 4.0.3-24 if I have time.
Comment 2 Florin Andrei 2001-07-26 16:22:15 EDT
So, you will send an updated XFree with this bugfix?
That would be so cool, because there are many systems out there with broken
Intel 440 mobos that cannot run X.
Comment 3 Mike A. Harris 2001-07-26 17:21:30 EDT
I will make unofficial binaries as I usually do on people.redhat.com,
and at some point an errata will be released but there is never
any defined ETA on any of our "Official" software release plans.

So if the Cirrus fixes work, they will be in future X errata whenever
that occurs.  XFree86 errata is something we wish to avoid as much as
possible by releasing less releases with more bugfixes.  Releasing
frequent updates puts a significant burden on our QA engineers.  This
is one reason I release test binaries on people.redhat.com.  99% of them
are rock solid and improve upon past official releases, even though they
are not official releases themselves.  Hope this helps understand the
X release strategy I use.
Comment 4 Mike A. Harris 2001-08-08 11:09:20 EDT
Cirrus fix reported working on several Cirrus chips in 4.1.0-0.9.11
release in rawhide.  My testing on a 5446 and a 543x cards show
the fix works.

Note You need to log in before you can comment on or make changes to this bug.