Bug 493943 - liveinst --debug on f11 beta produces traceback
liveinst --debug on f11 beta produces traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 08:03 EDT by Michal Hlavinka
Modified: 2009-04-07 14:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 14:05:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-04-03 08:03:26 EDT
Description of problem:
when trying to get more verbose output with 'liveinst --debug' it fails with traceback

[root@krles ~]# liveinst -d
umount: /media/*: not found
> /usr/sbin/anaconda(841)<module>()
-> import instdata
(Pdb) 
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 841, in <module>
    import instdata
  File "/usr/sbin/anaconda", line 841, in <module>
    import instdata
  File "/usr/lib64/python2.6/bdb.py", line 46, in trace_dispatch
    return self.dispatch_line(frame)
  File "/usr/lib64/python2.6/bdb.py", line 65, in dispatch_line
    if self.quitting: raise BdbQuit
bdb.BdbQuit



Version-Release number of selected component (if applicable):
kde livecd F11 beta
anaconda-11.5.0.38-1.x86_64

How reproducible:
allways

Steps to Reproduce:
1.boot livecd F11 beta
2.open terminal
3.su -
4.liveinst --debuginfo
  
Actual results:
fails with traceback

Expected results:
works with debugging informations

Additional info:
Comment 1 Chris Lumens 2009-04-06 12:52:48 EDT
What exactly are you trying to accomplish here?  --debug doesn't change the amount of logging.  It puts anaconda into a special mode that drops you into a PDB shell, enables debug buttons on various widgets, and so forth.  If you want additional output, you need to use --loglevel=debug instead.
Comment 2 Michal Hlavinka 2009-04-06 12:59:38 EDT
(In reply to comment #1)
> What exactly are you trying to accomplish here?  --debug doesn't change the
> amount of logging.  It puts anaconda into a special mode that drops you into a
> PDB shell, enables debug buttons on various widgets, and so forth.  If you want
> additional output, you need to use --loglevel=debug instead.  

I used it because I wanted more verbose output, so I can see I should use loglevel next time... but still there is an option that produces failure with traceback
Comment 3 Jeremy Katz 2009-04-07 14:05:14 EDT
It's not really so much that it produces failure with a traceback as you don't have input on the tty to anaconda and so pdb just quits immediately.

But since we don't really use --debug to accomplish that anymore, patch sent to get rid of it.

Note You need to log in before you can comment on or make changes to this bug.