Bug 493996 - system-config-cluster parses glade widget values incorrectly
system-config-cluster parses glade widget values incorrectly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
:
Depends On:
Blocks: 493997
  Show dependency treegraph
 
Reported: 2009-04-03 12:16 EDT by Shane Bradley
Modified: 2016-04-26 10:39 EDT (History)
9 users (show)

See Also:
Fixed In Version: system-config-cluster-1.0.57-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 493997 (view as bug list)
Environment:
Last Closed: 2010-06-07 10:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix tomcat/postgres (1.55 KB, patch)
2009-04-03 12:17 EDT, Shane Bradley
no flags Details | Diff

  None (edit)
Description Shane Bradley 2009-04-03 12:16:32 EDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

When using system-config-cluster the postgres and tomcat resource will not correctly assign the values from the resources widget to the associated cluster.conf field.

It appears that the ResourceHandler.py process_widgets function is pulling in the incorrect widgets entries for each of the corresponding member fields.

For example here is an incorrect cluster.conf resource that is created:

Name: testtomcat
Config File: /etc/tomcat5/tomcat5.conf
Tomcat User: tomcat
Catalina Options: -Dtest.test
Catalina Base: /usr/share/tomcat5
Shutdown Wait: 30

Resulting cluster.conf Fields seen:
 <tomcat-5 catalina_base="tomcat"
  catalina_options="/etc/tomcat5/tomcat5.conf"
  config_file="testtomcat"
  name="/usr/share/tomcat5"
  shutdown_wait="30"
  tomcat_user="-Dtest.test"/>


Reproducible: Always

Steps to Reproduce:
1.Create a tomcat and postgresql resource
2.Save the the configuration
3.Review the cluster.conf created
Actual Results:  
Some of the values are associated with incorrect fields.

Expected Results:  
The glade options should be associated with correct cluster.conf field.

Patch has been created and will be attached to the bz.
Comment 1 Shane Bradley 2009-04-03 12:17:30 EDT
Created attachment 338080 [details]
patch to fix tomcat/postgres
Comment 12 Chris Ward 2009-07-03 14:28:56 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 14 Brian Brock 2009-07-27 21:18:33 EDT
fix verified in system-config-cluster-1.0.57-1.3, the config file is written correctly, with the correct parameters & values for tomcat in cluster.conf.
Comment 16 Brian Brock 2009-07-28 10:34:08 EDT
changing state back to on_qa (from verified) due to a bug report from the field, that the new packages do not contain a full fix.  bug is already in needinfo for the same problem.
Comment 20 Ryan McCabe 2009-08-06 12:08:21 EDT
I just went through the resources glade file by hand, and I found the problem. All of the field names except shutdown wait are out of order. I've got a patch to fix this if it's not too late.
Comment 27 Brian Brock 2010-03-09 16:18:08 EST
current fix isn't complete, not all values are written.  using the info specified above, I get this in cluster.conf:

<resources>
        <apache __independent_subtree="1" config_file="/etc/httpd/conf/httpd.conf" httpd_options="" name="test1" server_root="/var/www/html" shutdown_wait=""/>
</resources>

at least shutdown_wait is not populated in cluster.conf, after giving it a value. s-c-cluster knows its value (30) until it exits.
Comment 32 Ryan McCabe 2010-06-07 10:25:41 EDT
Sorry -- that should read system-config-cluster-1.0.57-3 above.

Note You need to log in before you can comment on or make changes to this bug.