Bug 494007 - Clarify description of setting snapshot size for an LVM snapshot volume
Clarify description of setting snapshot size for an LVM snapshot volume
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks: 494009
  Show dependency treegraph
 
Reported: 2009-04-03 13:18 EDT by Steven J. Levine
Modified: 2009-09-03 12:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 494009 (view as bug list)
Environment:
Last Closed: 2009-09-03 12:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2009-04-03 13:18:43 EDT
Description of problem:
Jonathan Brassow forwarded a note from the lvm-development mailing list with a clear explanation of determining snapshot size. It was written by Bryn Reeves. He recommends I add this to the LVM document.

------------------------
The size of the snapshot governs the amount of space set aside for
storing the changes to the origin volume. E.g. if you made a snapshot
and then completely overwrote the origin the snapshot would have to be
at least as big as the origin volume to hold the changes.

You need to dimension a snapshot according to the expected level of
change. So for example a short-lived snapshot of a read-mostly volume,
e.g. /usr, would need less space than a long-lived snapshot of a volume
that sees a greater number of writes such as /home.

Snapshots can be grown after they have been created but you need to make
sure they don't fill up. If this happens the snapshot will become
invalid (since it can no longer faithfully track changes on the origin
volume).



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven J. Levine 2009-04-03 13:21:17 EDT
I am adding this information to the RHEL 4 and RHEL 5 versions of the LVM document. This will be in the RHEL 4.8 and the RHEL 5.4 releases (unless we have a major reason to update the online documents on the public web site earlier).
Comment 2 Steven J. Levine 2009-09-03 12:44:47 EDT
With the release of RHEL 5.4, I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.