Bug 494008 - mkinitrd silently fails if an image already exists
mkinitrd silently fails if an image already exists
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 13:19 EDT by Nathanael Noblet
Modified: 2009-04-03 13:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 13:25:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathanael Noblet 2009-04-03 13:19:31 EDT
Description of problem:

When building a new image (for example if the mobo has been replaced and new sata /scsi controller needs to be in the image). You run mkinitrd, however if the file exists, mkinitrd just quits, no error message

Version-Release number of selected component (if applicable):
F10 so far.

How reproducible:
Always

Steps to Reproduce:
1. mkinitrd /boot/initrd-KERNEL_VERSION.img KERNEL_VERSION
2.
3.
  
Actual results:
Prompt is returned

Expected results:
An error message stating that since an image exists already mkinitrd has exited.

Additional info:
Comment 1 Nathanael Noblet 2009-04-03 13:26:03 EDT
sorry - I had used an f9 version...

Note You need to log in before you can comment on or make changes to this bug.