Bug 494025 - osad installation on Fedora 10 fails due to Missing Dependency on python-optik
osad installation on Fedora 10 fails due to Missing Dependency on python-optik
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
0.5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Devan Goodwin
Red Hat Satellite QA List
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-04-03 14:36 EDT by Andrew Rechenberg
Modified: 2012-03-06 04:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 09:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Rechenberg 2009-04-03 14:36:45 EDT
Description of problem:

When trying to install osad on a fully updated Fedora 10 client the installation fails with a Missing Dependency error: python-optik


Version-Release number of selected component (if applicable):

osad-5.9.10-1.fc10.noarch

How reproducible:

Every time

Steps to Reproduce:
1. Install a fully updated Fedora 10 system
2. Try to install osad via 'yum install osad'

  
Actual results:

Fails with:
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package osad.noarch 0:5.9.10-1.fc10 set to be updated
--> Processing Dependency: jabberpy for package: osad
--> Processing Dependency: python-optik for package: osad
--> Running transaction check
---> Package jabberpy.noarch 0:0.5-0.17.fc10 set to be updated
---> Package osad.noarch 0:5.9.10-1.fc10 set to be updated
--> Processing Dependency: python-optik for package: osad
--> Finished Dependency Resolution
osad-5.9.10-1.fc10.noarch from spacewalk has depsolving problems
  --> Missing Dependency: python-optik is needed by package osad-5.9.10-1.fc10.noarch (spacewalk)
Error: Missing Dependency: python-optik is needed by package osad-5.9.10-1.fc10.noarch (spacewalk)


Expected results:
Clean installation
Comment 1 Kevin Arhelger 2009-05-13 00:37:05 EDT
Optik is not needed as python version is 2.5.2 (it's been in python since 2.3).
This is the same type of bug as https://bugzilla.redhat.com/show_bug.cgi?id=459204
Comment 2 Devan Goodwin 2009-07-23 15:51:42 EDT
We've removed this dependency today and the package will be rebuilt and available in the Spacewalk 0.6 devel repo soon. The code itself already checks if optparse is avail and falls back to python-optik if not, so the dependency removal was really all that was needed.
Comment 3 Devan Goodwin 2009-07-23 15:52:10 EDT
Going to immediately mark verified as a user has already tested the new package on Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.