Bug 49404 - linuxconf web access fails on changes update
linuxconf web access fails on changes update
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-19 01:10 EDT by Nikolai Turchanikov
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolai Turchanikov 2001-07-19 01:10:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i586; en-US; m18)
Gecko/20010131 Netscape6/6.01

Description of problem:
When linuxconf accessed via web browser (xinetd 2.3.0-1.71 installed)
the initial connection succeeds, but attempt to update a change
in configuration field fails.

the browser indicates broken connection (lynx message:
"Unexpected network error; connection aborted")

At the same time, xinitd syslog entry pops the message:
"warning: can't get client address: Transport endpoint is not
connected"

If linuxconf started with --http option, then everything works
fine with connection to the port 8000, thus indicating the
linuxconf-xinetd communication problem


How reproducible:
Always

Steps to Reproduce:
1.Ugrade (install) to xinetd 2.3.0-1.71
2.Make appropriate linuxconf and xinetd configuration to enable web access
to linuxconf (as per Red Hat documentation)
3.Start browser with http://localhost:98
4.Change contents of any field and press button "Accept"
	

Actual Results:  failed to accept configuration changes


Expected Results:  expected to accept and update configuration changes


Additional info:

Lynx error message:
"Unexpected network error; connection aborted"

Xinetd warning message:
"warning: can't get client address: Transport endpoint is not
connected"

The version of xinetd that comes with Red Hat 7.1 CDs does not
work with linuxconf at all, therefore the upgrade to the recently
posted updated xinetd version (2.3.0-1.71) is required
Comment 1 Brent Fox 2002-06-05 12:21:31 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.