Bug 494044 - Windows guest won't start with no CD in drive
Windows guest won't start with no CD in drive
Status: CLOSED DUPLICATE of bug 473154
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 16:33 EDT by Russell Doty
Modified: 2009-12-04 11:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 18:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Doty 2009-04-03 16:33:19 EDT
Description of problem:
Windows guest won't run with no CD in drive.

Version-Release number of selected component (if applicable):
Fedora 11 Beta

How reproducible:
Every time

Steps to Reproduce:
1. Create a Windows guest
2. Remove CD from drive
3. Attempt to start guest
  
Actual results:

Guest doesn't start.

Error starting domain: internal error unable to start guest: qemu: could not open disk image /dev/sr0

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 493, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 573, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 287, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: qemu: could not open disk image /dev/sr0


Expected results:
Guest starts.

Additional info:
I have run into this before in earlier versions of Fedora. Suggest either modifying the code so that a Windows guest can start with no CD in the drive or adding additional explanation to the error message telling people what the problem is and what they can do to correct it (either disconnect the CD in the VM manager or insert a CD in the drive.)
Comment 1 Cole Robinson 2009-04-04 18:09:37 EDT

*** This bug has been marked as a duplicate of bug 473154 ***

Note You need to log in before you can comment on or make changes to this bug.