Bug 494059 - recorded sound is defective
recorded sound is defective
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-03 17:58 EDT by James Bridge
Modified: 2010-06-28 07:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 07:41:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Bridge 2009-04-03 17:58:06 EDT
Description of problem:
recorded sound (ogg file, from mic) has rapid alternation of sound and silence - the sound appears to be the actual recorded sound, but it is constantly interrupted. Sounds like machine gun fire!

Version-Release number of selected component (if applicable):
F11 beta livecd

How reproducible:

Steps to Reproduce:
1. try to record!
Actual results:

Expected results:

Additional info: similar problem with F10, reported as bug 482932. However, in that case it only happened if the PA volume control was not open. Now it happens all the time.

FWIW, I don't see it as progress that you now have to use the terminal in order to select input from line input. How else do you get stereo input?
Comment 1 Bastien Nocera 2009-04-29 06:46:32 EDT
Version of gnome-media? Did you test with 2.26.0?

Does the same problem happen when using arecord to record the audio?
Comment 2 James Bridge 2009-04-29 18:59:17 EDT
I just used the F11 live CD. That has gnome-sound-recorder 2.25.92.

Haven't tried yet with arecord. Will get back to you
Comment 3 James Bridge 2009-04-30 13:44:52 EDT
arecord works, as does sound-recorder when making a wav file. But using the live cd I haven't found any way of recording from line input. I can only record from the mike. I tried playing with alsamixer, but couldn't find anything relevant.
Comment 4 Bastien Nocera 2009-05-05 10:12:44 EDT
Does this work:
gst-launch-0.10 pulsesrc ! audio/x-raw-float,rate=44100,channels=2 ! vorbisenc name=enc quality=0.5 ! oggmux ! filesink location=foo.oga
And then play the "foo.oga" using ogg123?

Or this:
gst-launch-0.10 pulsesrc ! wavenc ! filesink location=foo.wav
And then playing foo.wav using paplay?

Is it the playback that's broken, or the recording itself?
Comment 5 James Bridge 2009-05-07 13:07:41 EDT
Both work, though only from the microphone. I can't find any way of enabling line input. System > Preferences > Sound and Applications > Sound & Video > PulseAudio Volume Control both simply refer to "Internal Audio". Alsamixer just has one control for input volume.
Comment 6 Bug Zapper 2009-06-09 09:14:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 7 Bug Zapper 2010-04-27 09:29:41 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2010-06-28 07:41:15 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.