Bug 494076 - RFE - Filesystem types and partition order
RFE - Filesystem types and partition order
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2009-04-03 21:23 EDT by Phil
Modified: 2013-01-10 00:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 19:54:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil 2009-04-03 21:23:00 EDT
Description of problem/request:
During the partitioning phase I find it impossible to create a partition and either leave it as "unformatted" or format it as NTFS.  Considering the level of support for NTFS I'm surprised this isn't already an option like it is with some other distributions.  It seems that dual boot systems are more and more common and as there are already tools in place to resize existing partitions for this purpose adding the ability to do the whole thing during install would be a big advantage.

An example would be my own system where i wanted to delete all partitions on my raid0 array and start from scratch, i wanted to do the following:

Part1 = C:\ = 16GB
Part2 = D:\ = 100GB+
Part3 = /boot = 256MB
Part4 = LVM = 20GB

I prefer to separate C and D for when windows needs to be rebuilt and windows seems to have major issues when installed on to something other than the first partition.

With the partitioning wizard the way it is you can't format as NTFS or just leave it unformatted, you are also unable to specify partition order.  Despite want/needing the partition order to be like it is above, /boot is always made the first partition.  I have heard that this is to ensure the system boots properly but provided /boot is on a primary part and not on an extended then it will/should always work.

As a work around I could do half an install of windows first or use a live cd for partitioning but it's double handling and forcing people away from trusting the fedora installer to do it all.
Comment 1 Phil 2009-04-04 19:31:43 EDT
a thought:
when you click the radio button to "force to be primary part" have a combo box next to it that allows you to specify part number - simple up/down arrow for 1-4.  it should be easy enough to do a quick check and warn if the part already exists too.
Comment 2 Phil 2009-04-04 19:38:00 EDT
having full NTFS support would also allow people to specify a mount point for their C:\ under dual boot situations.  provided there is a blocker in place for people trying to install / or other parts of the LFS on to NTFS like happens with /boot and ext4 then all should be good :).
Comment 3 Joel Andres Granados 2009-09-03 07:30:43 EDT
(In reply to comment #1)
> a thought:
> when you click the radio button to "force to be primary part" have a combo box
> next to it that allows you to specify part number - simple up/down arrow for
> 1-4.  it should be easy enough to do a quick check and warn if the part already
> exists too.

This is not a good approach as it is only valid for msdos labels.  Most of the other partition table types dont have the 4 primary partition table restriction
Comment 4 Joel Andres Granados 2009-09-03 07:31:57 EDT
(In reply to comment #0)
> Description of problem/request:
> During the partitioning phase I find it impossible to create a partition and
....
> With the partitioning wizard the way it is you can't format as NTFS or just
> leave it unformatted, 

I think you can leave unformated with current anaconda.  Pls test with anaconda.12-20 or greater.
Comment 5 David Lehman 2009-09-03 18:31:39 EDT
If you want to create a partition to later create an NTFS filesystem on, just create the partition and format it as ext3 or anything else. This will not prevent you from later overwriting the filesystem with NTFS.
Comment 6 Phil 2009-09-03 19:33:42 EDT
(In reply to comment #3)
> 
> This is not a good approach as it is only valid for msdos labels.  Most of the
> other partition table types dont have the 4 primary partition table
> restriction  

Aren't all new disks initialised with msdos labels anyway?  In my experience the only distro that didn't use the standard 4 primary part table was pfSense which is freeBSD based.  Even if the part table isn't msdos surely the limits of other table types are known so you could specify 1-8 for example.  My main query/request was that the order of partitions be specified and I accept that to recode this may be a lot of work for seemingly little gain.  But, I think it would help add to the Fedora install experience that when a super user opts for a custom partition layout that s/he have full control over what goes where and what type it is.


(In reply to comment #4)
>
> I think you can leave unformated with current anaconda.  Pls test with
> anaconda.12-20 or greater.

I won't be able to check for a couple of weeks but will hopefully be trialling the alpha soon.


(In reply to comment #5)
> If you want to create a partition to later create an NTFS filesystem on, just
> create the partition and format it as ext3 or anything else. This will not
> prevent you from later overwriting the filesystem with NTFS.

Yeah, that's how i got around the problem but it's a pretty clunky way to do it.  Are there any license limitations that prevent Fedora from including NTFS support in anaconda?


thanks,
pb
Comment 7 David Lehman 2009-09-04 13:21:39 EDT
Anaconda's partitioning interface aims to be simple, intuitive, and flexible for most users. The amount of work to implement the functionality you describe is prohibitive given the very low demand. If you have a high level of expertise and a very specific set of requirements you can always partition in advance using parted, fdisk, or whatever tool you prefer.
Comment 8 Phil 2009-09-05 15:05:44 EDT
Cool and I understood.  My RFE was just to see if others thought the same but it's all good.  My thought was in comparison to Ubuntu's installer that allows you to format partitions as NTFS.  With me being the super user I am there is no real inconvenience - not meaning to sound too pretentious but I'm an RHCE who's been using Fedora since Core 4 - but was just thinking of the average user wanting to dual boot and have their files that s/he made under windoze easily accessible from Fedora.  I'd like to see the addition of NTFS to anaconda but wholly understand the programming constraints.

thank you all and respect for what you do, it is humbly appreciated,

Regards,

Phil

Iron Maiden - The Clansman:
http://www.youtube.com/watch?v=TaJKDYZ-n38


I will be happy to see this bug closed if it is seen fit by the powers that be :)
Comment 9 Joel Andres Granados 2009-09-08 11:06:34 EDT
(In reply to comment #6)
> (In reply to comment #3)
> > 
> > This is not a good approach as it is only valid for msdos labels.  Most of the
> > other partition table types dont have the 4 primary partition table
> > restriction  
> 
> Aren't all new disks initialised with msdos labels anyway?  

This, though true, is not a reason to make decisions for the future.  In this specific case the msdos partition table type is becoming obsolete as it only allows 2T addressing.  With device-mapper and 250Gb drives, this is fast becoming something common.

> In my experience
> the only distro that didn't use the standard 4 primary part table was pfSense
> which is freeBSD based.  Even if the part table isn't msdos surely the limits
> of other table types are known so you could specify 1-8 for example.

Not really,  I'm pretty sure that, theoretically, gpt can have as many partitions as the disk can hold (Which depends on disk size etc, etc. it get complicated really fast).  I'm speaking from the gpt specification point of view.

>  My main
> query/request was that the order of partitions be specified and I accept that
> to recode this may be a lot of work for seemingly little gain.  But, I think it
> would help add to the Fedora install experience that when a super user opts for
> a custom partition layout that s/he have full control over what goes where and
> what type it is.

One can already do this by working in tty2 before the installer goes and finds the storage.  Its not recommended, because you can very easily shoot yourself in the foot, but its possible.

> 
> 
> (In reply to comment #4)
> >
> > I think you can leave unformated with current anaconda.  Pls test with
> > anaconda.12-20 or greater.
> 
> I won't be able to check for a couple of weeks but will hopefully be trialling
> the alpha soon.

great!
Comment 10 Phil 2009-10-11 01:54:52 EDT
Just did an install of both x64 and then i386 and can report the following.

* There is no option to leave a newly created partition "unformatted"

* While I could create a GPT on my 2.1TB jbod there was a problem with anaconda regarding this id=528276
Comment 11 Manuel Faux 2010-08-19 16:38:46 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Jesse Keating 2012-07-19 19:54:22 EDT
Closing per comment #8

Note You need to log in before you can comment on or make changes to this bug.