This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 494086 - hard disk install non functional in fedora 11 beta
hard disk install non functional in fedora 11 beta
Status: CLOSED DUPLICATE of bug 491781
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-03 23:41 EDT by Tom Horsley
Modified: 2009-04-04 14:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-04 14:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2009-04-03 23:41:36 EDT
Description of problem:

This grub entry points to the files I extracted from the DVD iso image:

title Install Fedora 11 Beta
	root (hd0,6)
	kernel /boot/fed11/vmlinuz repo=hd:/dev/sdb2:/downloads/otherinbox/Fedora-11-Beta-x86_64-DVD
	initrd /boot/fed11/initrd.img

I had to unplug my USB drive to make this work since for some reason in the
kernel for the installer, the usb drive came up as /dev/sdb and the hard disk
which is normally /dev/sdb came up as /dev/sdc. With the usb drive unplugged
things get farther (but that is really just a side issue however weird it
might seem).

The Fedora-11-Beta-x86_64-DVD directory referenced above looks like this:
total 4258208
-rw-r--r-- 1 tom  users       1658 Apr  3 17:04 Fedora-11-Beta-x86_64-CHECKSUM
-rw-r--r-- 1 tom  users 4356126720 Apr  3 20:37 Fedora-11-Beta-x86_64-DVD.iso
drwxr-xr-x 2 root root        4096 Apr  3 23:00 images

./images:
total 103000
-rw-r--r-- 1 root root 105361408 Apr  3 23:00 install.img

The images/install.img file is copied from the images directory on the
iso.

I boot this grub entry, the kernel boots, it asks about the keyboard, I
get to the anaconda initial GUI and click on the Install Anyway button
when it asks about installing beta software, then the next thing
that comes up is an error dialog that says:

"The installation source given by /dev/sdb2 could not be found."

I try again with LABEL=ZOOTY instead of /dev/sdb2, but the same thing
happens.

It clearly claimed to be running anaconda and some GUI bits showed up,
so I assume it found something to start running, but then I guess it
lost track of it :-).

If the HD install procedurs have radically changed once again, I
couldn't find any pointers to the new procedures to use.

Version-Release number of selected component (if applicable):
Fedora 11 beta DVD image.

How reproducible:
Every time

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
see above

Expected results:
actually getting the install going would be nice

Additional info:
Comment 1 Gireesh Sreekantan 2009-04-04 14:11:43 EDT
This is a known issue already documented in the F11 beta release notes.

https://fedoraproject.org/wiki/Fedora_11_Beta_release_notes#Anaconda_installer_issues

There is a bug 491781 already opened for this. Hence I am closing this out an duplicate.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 491781 ***

Note You need to log in before you can comment on or make changes to this bug.