Bug 49409 - Can't tell what "rpm --freshen *.rpm" will do
Can't tell what "rpm --freshen *.rpm" will do
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-19 03:34 EDT by kop
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 20:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kop 2001-07-19 03:34:18 EDT
Description of Problem:

There is no way to test for which packages will be upgraded by --freshen. 
This greatly reduces the utility of --freshen because you can't tell if
you're going to get into something complicated, as when a complex config
file is upgraded and you need to be sure your config and the new software
are in sync, or something dangerous, like a upgrade to the kernel.  This is
especially significant when trying to apply the updates from RedHat, as
lots of update rpms wind up in one directory.

I'd like some combination of -v --freshen and --test to provide clues as to
what's going to happen.  Or at least what packages are going to be
freshened.
Comment 1 Jeff Johnson 2001-07-19 17:16:46 EDT
Try
	rpm -Fvv --test --noscripts --notriggers ...
The output is copious, but complete. (And, AFAIK, --noscripts
and --notriggers are implied by --test, but Just In Case ...)
Comment 2 kop 2001-07-19 20:02:30 EDT
I'll grant that -Fvv is acceptable if you'll commit to a particular script,
like:

rpm -Fvv --test --noscripts --notriggers *.rpm 2>&1 | grep '^D: package: ' | cut
-d ' ' -f 3

which will _allways_ produce the list of new packages to be installed.  If you
won't commit, I stick by my claim that "There is no way to test for which
packages will be upgraded by --freshen."

(I wouldn't take the bait if I were you...  :-)
Comment 3 Jeff Johnson 2001-07-24 13:12:26 EDT
I'll commit to a relatively simple, deterministic way of identifying
what packages are gonna be installed, but I reserve the right to
change the "D: package:" string if I need to. How's that? :-)

Note You need to log in before you can comment on or make changes to this bug.