Bug 494092 - Liberation fonts under GTK applications cannot render with antialiasing
Liberation fonts under GTK applications cannot render with antialiasing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 01:05 EDT by Hasan Ceylan
Modified: 2009-06-30 22:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 22:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hasan Ceylan 2009-04-04 01:05:54 EDT
Description of problem:
I am using KDE. I can use liberation fonts just fine for KDE applications. However for GTK applications fonts cannot render as antialiased. 

Here's a matrix of what combination works and what not:
GNOME + Liberation NO
KDE + Liberation OK
Under KDE GTK Apps + Liberation NO
Under KDE GTK Apps + Sans Serif / Monospace YES


Version-Release number of selected component (if applicable):
rawhide + F10

How reproducible:
Everytime

I really would like to use Liberation fonts as I favour them on any other ones.

Regards,
Hasan Ceylan
Comment 1 Hasan Ceylan 2009-04-05 05:00:10 EDT
I do not know what's going on under the hood but here's what works for me.

Credit goes to http://gordonazmo.wordpress.com/2008/03/27/a-simple-tweak-to-make-your-gtk-fonts-look-nice-in-kde/ 

I already had gtk-qt-engine-1.1-5.fc11.i586.

I cannot test GNOME right now but at least for GTK apps under KDE that solution works for me.

So a missing link is resotered by
#ln -s /etc/fonts/conf.avail/10-autohint.conf /etc/fonts/conf.d/

I do not know which rpm should be responsible for providing this symbolic link therefore I will leave the subject and category as it is although my initial guess is totally wrong.

Hasan
Comment 2 Caius Chance 2009-04-05 19:52:19 EDT
Thanks, Hasan.

FYI, 10-autohint.conf was not symlinked to conf.d/ has many reasons. '10' is very high priority which overrides most of other specification in other .conf files.

Ones might prefer Auto Hint for everything, but there are other ones who don't. There are some users who are in locales that auto hinting blur their default fonts due to glyph complexity. This simply affect their usage.

We could work out a more appropriate solutions to suit both cases.
Comment 3 Bug Zapper 2009-06-09 09:15:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Caius Chance 2009-06-30 22:59:50 EDT
Zap this bug. Please reopen if bug persists after testing on latest version.

Note You need to log in before you can comment on or make changes to this bug.