Bug 494094 - dnsmasq should start at 49 instead of 99
dnsmasq should start at 49 instead of 99
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 04:07 EDT by Jarkko
Modified: 2009-11-19 02:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 499100 (view as bug list)
Environment:
Last Closed: 2009-11-19 02:46:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarkko 2009-04-04 04:07:27 EDT
I noticed ntpdate fails during startup. That happens because I have localhost (dnsmasq) at /etc/resolv.conf and actual remote name servers at /etc/resolv.dnsmasq - and dnsmasq starts later than ntpdate.

The correct order number for startup seems to be 49 because yum.cron is at 50 and it needs name service.

If you change the order number, could you please release the update for F9, F10 and rawhide. Thanks.
Comment 1 Bug Zapper 2009-06-09 09:15:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Patrick Laughton 2009-06-11 10:16:35 EDT
Hey, no fair, Bug Zapper!

A fixed 2.48-1 is in the pipes for Rawhide.  Do you think I should push it for F11, too?

Sorry for the delay in addressing this, and thanks for pointing it out.
Comment 3 Jarkko 2009-06-11 15:51:22 EDT
Yes I think it's a good idea to push the fix for F11.
Comment 4 Patrick Laughton 2009-06-12 10:11:35 EDT
Err, for upgrades, I'm going to need to do `chkconfig --del dnsmasq`/`chkconfig --add dnsmasq`, so that it has the updated symlinks, aren't I?  Mildly annoying, but fairly necessary, I imagine.  Might be wise to add that to Rawhide's copy, too.  Oops. :-\
Comment 5 Jarkko 2009-06-13 02:29:51 EDT
Perhaps `chkconfig --override dnsmasq` would do what we need.
Comment 6 Itamar Reis Peixoto 2009-10-05 02:29:03 EDT
(In reply to comment #5)
> Perhaps `chkconfig --override dnsmasq` would do what we need.  

that's true,  the chkconfig has been changed to 49 into devel package, I think will be a good idea to have it in f-10 and f-11 too.
Comment 7 Itamar Reis Peixoto 2009-11-19 02:46:51 EST
fixed in rawhide and in F-12

Note You need to log in before you can comment on or make changes to this bug.