Bug 494102 - Anaconda does not activate LVM volumes
Anaconda does not activate LVM volumes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 07:56 EDT by Ahmed Kamal
Modified: 2009-07-21 10:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 13:54:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (113.51 KB, text/plain)
2009-04-06 13:53 EDT, Ahmed Kamal
no flags Details
anaconda.syslog (51.66 KB, text/plain)
2009-04-06 13:54 EDT, Ahmed Kamal
no flags Details
anaconda.xlog (40.94 KB, text/plain)
2009-04-06 13:54 EDT, Ahmed Kamal
no flags Details
Storage.log (program.log not available) (171.55 KB, text/plain)
2009-04-06 20:30 EDT, Ahmed Kamal
no flags Details
anaconda.log (59.72 KB, text/plain)
2009-07-20 23:13 EDT, Richard Shaw
no flags Details
anaconda.syslog (42.50 KB, text/plain)
2009-07-20 23:13 EDT, Richard Shaw
no flags Details
anaconda.xlog (45.61 KB, text/plain)
2009-07-20 23:13 EDT, Richard Shaw
no flags Details
storage.log (95.55 KB, text/plain)
2009-07-20 23:14 EDT, Richard Shaw
no flags Details

  None (edit)
Description Ahmed Kamal 2009-04-04 07:56:31 EDT
Description of problem:
I have F10 installed on my laptop, with the root on a LVM LV. I have created a new LV for F11. However, booting the DVD, the installer did not seem to activate the LVM groups, as they were NOT shown in the list of devices to install on. I tried clicking on the "LVM" button in anaconda and so on .. but that did not help. Failing back to a shell, and typing "lvm lvdisplay" resulted in me viewing my LVs, but their status was "NOT AVAILABLE" !! I then manually activated them using the command
"lvm vgchange -a y"
Afterwards, I jumped back to GUI, click the "back" button .. then the forward button again, and the LVM LVs were there. I chose one, and installed on it successfully

Version-Release number of selected component (if applicable):


How reproducible:
I can only do this once ;)

Steps to Reproduce:
1. Try to install F11 on a system with already LVs available
2. Anaconda's storage manager does not show/activate LVM
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-04-06 12:54:38 EDT
Can you attach /tmp/storage.log and /tmp/program.log from your install to this bug report?  If you've gone ahead and continued with the install, they'll be in /var/log/anaconda.* instead.  Thanks.
Comment 2 Ahmed Kamal 2009-04-06 13:52:26 EDT
Yes I went ahead with the installation. Attaching /var/log/anaconda.*
Comment 3 Ahmed Kamal 2009-04-06 13:53:39 EDT
Created attachment 338369 [details]
anaconda.log
Comment 4 Ahmed Kamal 2009-04-06 13:54:16 EDT
Created attachment 338370 [details]
anaconda.syslog
Comment 5 Ahmed Kamal 2009-04-06 13:54:56 EDT
Created attachment 338371 [details]
anaconda.xlog
Comment 6 David Lehman 2009-04-06 20:17:30 EDT
If you can find storage.log and/or program.log in /var/log, please attach them.
Comment 7 Ahmed Kamal 2009-04-06 20:30:53 EDT
Created attachment 338418 [details]
Storage.log (program.log not available)
Comment 8 David Lehman 2009-04-06 20:44:48 EDT
It looks like something fixed in anaconda-11.5.0.39-1. The problem is/what that the timeout given to udev_settle was too short for it to be able to identify the formatting on all of your storage devices. Please try again using this newer version of anaconda (it's in rawhide) and see if that solves your problem.
Comment 9 Bug Zapper 2009-06-09 09:15:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Richard Shaw 2009-07-20 23:11:12 EDT
Not sure if my problem was the same as this one. I'm also not sure if it's proper to post my problem to this closed bug or create a new one but here it goes anyway.

I had a similar problem when installing F11 on top of F10. Under F10 I was running out of space so I added an additional drive and used system-config-lvm to initialize it and created a new volume group/logical volume. I noticed at the time that it used the whole disk instead of creating a primary partition on the drive. Per the LVM howto this is not recommended because:

"Using the whole disk as a PV (as opposed to a partition spanning the whole disk) is not recommended because of the management issues it can create. Any other OS that looks at the disk will not recognize the LVM metadata and display the disk as being free, so it is likely it will be overwritten. LVM itself will work fine with whole disk PVs."

However, i'm in Linux 99% of the time and only reboot to my XP partition for some games and to remote into work so no big deal.

I ran into an issue when I booted the F11 install DVD and found that it detected my system VG/LV (which I overwrote to prevent any upgrade issues) but preserved my /home on the second drive VG/LV. The problem is that anaconda did not detect my /home LV. I presume this is because the VG is using the whole disk instead of a partition but I'm not sure. I will attach my storage.log and anaconda.log
Comment 11 Richard Shaw 2009-07-20 23:13:08 EDT
Created attachment 354426 [details]
anaconda.log
Comment 12 Richard Shaw 2009-07-20 23:13:34 EDT
Created attachment 354427 [details]
anaconda.syslog
Comment 13 Richard Shaw 2009-07-20 23:13:55 EDT
Created attachment 354428 [details]
anaconda.xlog
Comment 14 Richard Shaw 2009-07-20 23:14:29 EDT
Created attachment 354429 [details]
storage.log
Comment 15 Chris Lumens 2009-07-21 10:45:14 EDT
You are correct about the whole disk thing - anaconda does not currently support using the whole disk for a PV or RAID member.  It requires using a partition.  We have a bug to track that support somewhere, and are hoping to have it completed in time for F12.

Note You need to log in before you can comment on or make changes to this bug.