Bug 494103 - Anaconda does not detect older Fedoras (in grub.conf)
Anaconda does not detect older Fedoras (in grub.conf)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 08:04 EDT by Ahmed Kamal
Modified: 2009-06-02 10:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 10:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ahmed Kamal 2009-04-04 08:04:20 EDT
Description of problem:
Installing F11 on a system with F10. I chose my to use my older /boot partition, and NOT to format it. F11 overwritten F10's grub.conf and did not append to it!

Version-Release number of selected component (if applicable):


How reproducible:
Can only test once

Steps to Reproduce:
1. Install F11 on a system with F10, choose your existing /boot patition
2. F11 installer finishes, rebooting into the new system, the entries for F10 are lost!
3.
  
Actual results:
F10 grub.conf entries are lost

Expected results:
F11 appends to F10's grub.conf and I can boot either F10 or F11

Additional info:
Comment 1 Chris Lumens 2009-05-18 11:54:29 EDT
*** Bug 501063 has been marked as a duplicate of this bug. ***
Comment 2 James Laska 2009-05-27 10:16:35 EDT
Ahmed: so you are installing on top of F10 and choosing to use, but *not* reformat, the existing '/boot' partition.  If that is the case, I don't believe you can expect any existing bootloader configuration to remain intact since anaconda will install a new bootloader.  

If you wish to add entries for existing boot targets, you can do that in the anaconda bootloader screen, or by hand post-install.
Comment 3 Allen Kistler 2009-05-29 05:31:20 EDT
I multi-boot all the time using a common /boot, so I'm quite familiar with how anaconda/grub handles installing the bootloader when there's already one installed and configured.

1. There's only one MBR, so there can be only one binary.
   The stage files get overwritten to match what's in the MBR.
   That's the way you *want* it to be.

2. The existing grub.conf and menu.lst are moved to grub.conf.rpmsave and
   menu.lst.rpmsave.  They're not deleted.  menu.lst is a logical link, so
   it doesn't make a lot of sense to mv it, but it doesn't hurt anything.
   (Remember that grub.conf is really in /boot/grub, not in /etc, just 
    where you *want* it to be, eh?)

After you boot into the new OS, just run
cat grub.conf.rpmsave >> grub.conf
then vi it to get rid of the duplicate header lines and "rm *rpmsave"

Getting anaconda and/or grub to edit the existing grub.conf rather than mv it would be nice, but it works fine the way it is.  That's also the way it's always worked since grub has been the bootloader.  (lilo.conf really did go in /etc, but you could pull some link fakery like grub does now, too.)

If the old grub.conf really did get blown away, there'd be a lot of angry folks racing you to file a bug on it.  As it is, I'd say this one is a WORKSFORME (alpha through preview so far).

HTH
Comment 4 Joel Andres Granados 2009-05-29 08:47:16 EDT
comment #3 sounds pretty much right.

Another thing you could do (What I do in my installs) is to tell anaconda not to install a bootloader.  This will skip the installation of the grub package and avoid all the grub.conf.rpmsave stuff.  You do have to edit the grub.conf with the parameters of your new install though.

+1 for WORKSFORME
Comment 5 James Laska 2009-06-02 10:02:20 EDT
Closing this bug out.  Comment#3 and Comment#4 offer recommendations to retain any existing bootloader configuration when reinstalling without formatting '/boot'.

Please file a new bug should any problems be encountered while testing the suggested solutions.

Note You need to log in before you can comment on or make changes to this bug.