Bug 494109 - When starting mplayer there is a 3-4 second delay when opening a file
When starting mplayer there is a 3-4 second delay when opening a file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 09:17 EDT by Kevin DeKorte
Modified: 2009-04-10 15:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 15:50:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info for my machine (33.47 KB, text/plain)
2009-04-08 16:19 EDT, Kevin DeKorte
no flags Details

  None (edit)
Description Kevin DeKorte 2009-04-04 09:17:25 EDT
Description of problem:
When running mplayer under pulseaudio in rawhide, when you start a audio or video the mplayer counter pauses and the video frames are stalled, then after about 3 or 4 seconds the counter starts and the video frames catch up.

When I set the ao to null, I don't see this odd lag at the start. This also happens when mplayer is using the alsa ao (which pulseaudio emulates). I was using this same setup in Fedora 10 and did not this the problem there.

Version-Release number of selected component (if applicable):
pulseaudio-libs-0.9.15-8.test7.fc11.i586
pulseaudio-module-x11-0.9.15-8.test7.fc11.x86_64
pulseaudio-0.9.15-8.test7.fc11.x86_64
pulseaudio-utils-0.9.15-8.test7.fc11.x86_64
pulseaudio-libs-zeroconf-0.9.15-8.test7.fc11.i586
pulseaudio-libs-devel-0.9.15-8.test7.fc11.i586
pulseaudio-libs-0.9.15-8.test7.fc11.x86_64
pulseaudio-module-gconf-0.9.15-8.test7.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-8.test7.fc11.x86_64
pulseaudio-libs-glib2-0.9.15-8.test7.fc11.i586


How reproducible:
100%

Steps to Reproduce:
1. Install mplayer from rpmfusion (x86_64 or i386 version)
2. start mplayer with -vo x11 and -ao pulse with any video file
3.
  
Actual results:
The A: counter will stagger and sometimes go backwards (negative values)

Expected results:
The A: counter should progress smoothly

Additional info:
Comment 1 Kevin DeKorte 2009-04-07 12:41:46 EDT
Seems to happen when playing the first file after no audio activity for about 5 - 10 seconds, so perhaps it is a delay in the wake up of pulse audio
Comment 2 Lennart Poettering 2009-04-07 16:47:53 EDT
Hmm, if you comment the "load-module module-suspend-on-idle" in /etc/pulse/default.pa and then relogin (or restart pa), does the problem go away?
Comment 3 Kevin DeKorte 2009-04-07 17:06:30 EDT
It seems to help some, but I still get some delay but not everytime. Seems to be a little more random as to when it will happen now.
Comment 4 Warren Togami 2009-04-08 02:02:51 EDT
http://www.pulseaudio.org/ticket/440
Isn't this the issue?  mplayer itself points at this pulseaudio bug when this delay happens.

Something very similar happens when I try to play Youtube videos.
Comment 5 Kevin DeKorte 2009-04-08 08:45:12 EDT
I am running SVN of mplayer that has a workaround for that bug in it, this is at the very beginning of playing the file.. it seems like some audio buffer is filling but mplayer is not receiving a message back that the buffer is ready or played..
Comment 6 Kevin DeKorte 2009-04-08 16:18:45 EDT
I disabled glitch free audio by adding tsched=0 to the module-hal-detect line and it appears to have solved the problem.

According to http://pulseaudio.org/wiki/BrokenSoundDrivers

my card should already be fixed...

Since it is an snd-intel-hda with the ALC883 codec. I have attached the output from alsa-info.sh to this ticket.
Comment 7 Kevin DeKorte 2009-04-08 16:19:51 EDT
Created attachment 338795 [details]
alsa-info for my machine

my speakers are connected to 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)

and 

01:00.1 Audio device: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series]

Is not used
Comment 8 Kevin DeKorte 2009-04-09 16:48:22 EDT
I removed tsched=0 and pulled pulseaudio from git and rebuilt the rpms (without any patches) based on this git snapshot. So far things seem to be a little better. Perhaps another snapshot of pulseaudio could be released?
Comment 9 Kevin DeKorte 2009-04-10 11:26:46 EDT
pulseaudio 0.9.15-9 seems to have corrected this, I believe you can close this bug.
Comment 10 Lennart Poettering 2009-04-10 15:50:21 EDT
Closing then.

Note You need to log in before you can comment on or make changes to this bug.