Bug 494111 - volid recognizing zfs partitions as ext3
volid recognizing zfs partitions as ext3
Status: CLOSED DUPLICATE of bug 494070
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 09:20 EDT by Eric Sandeen
Modified: 2009-10-27 05:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 05:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2009-04-04 09:20:37 EDT
I don't know for sure how much we can do a about this (blkid has the same problem) but bug #494070 and bug #490795 both had users w/ zfs partitions which are recognized as ext3 by both blkid & volid, due to stale ext3 magic.

Really, it would be nice if mkfs.zfs would zero these old signatures, but perhaps we can have better detection of zfs...

I'm not sure what detection algorithm udev uses, but blkid uses VDEV_BOOT_MAGIC, which doesn't seem present in either endianness on the disk snippets I've seen:

# hexdump -C sda2-first-1M | grep "0c b1 07 b0 f5 02 00 00"
# hexdump -C sda2-first-1M | grep "00 00 02 f5 b0 07 b1 0c"

# hexdump -C first_400K | grep "0c b1 07 b0 f5 02 00 00"
# hexdump -C first_400K | grep "00 00 02 f5 b0 07 b1 0c"

but the "uberblock" magic is present in both:

# hexdump -C sda2-first-1M | grep "0c b1 ba 00"
00015e30  30 e8 ff ff 85 c0 5b 75  48 8b 06 35 0c b1 ba 00
# hexdump -C first_400K | grep "0c b1 ba 00"
00015e30  30 e8 ff ff 85 c0 5b 75  48 8b 06 35 0c b1 ba 00

I've asked the person @sun.com who submitted the blkid patch about this, and I can provide the above 2 chunks of data for testing if desired.

Thanks,
-Eric
Comment 1 Bug Zapper 2009-06-09 09:16:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Karel Zak 2009-10-27 05:13:18 EDT

*** This bug has been marked as a duplicate of bug 494070 ***

Note You need to log in before you can comment on or make changes to this bug.