Bug 494130 - virtual terminal logins are disabled during firstboot
virtual terminal logins are disabled during firstboot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 17:20 EDT by Andrew McNabb
Modified: 2009-09-08 15:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 15:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNabb 2009-04-04 17:20:07 EDT
Virtual terminals have no login prompts during firstboot.  When I do Ctrl-Alt-F2, I get a blank screen, and there's no way to log in.  I can't think of any reason not to enable logins on virtual terminals, and they would really help for the situation where a user really knows what they're doing and wants to bypass firstboot.  This is especially important because firstboot is deliberately designed to not let advanced users do anything that might be harmful for less advanced users (see bug #474007).  Without virtual terminals, advanced users have no recourse but to reboot in single user mode.  Enabling virtual terminals wouldn't hurt less advanced users, but it would be very helpful for advanced users.
Comment 1 Andrew McNabb 2009-04-21 14:32:27 EDT
I noticed that you can hit Ctrl-Alt-Backspace in firstboot to quit it.  This is a partial workaround.
Comment 2 Chris Lumens 2009-06-01 16:55:03 EDT
I don't believe there's anything firstboot can do here.  firstboot is started as a service by upstart just like everything else.  When it's done, then I believe we move on to firing off the other events that start shells on the ttys.  If there's a way around it, I'm all for it.  I just don't know what's possible and what's not using upstart.
Comment 3 Andrew McNabb 2009-06-02 13:19:50 EDT
I'm not really familiar with Upstart, but it seems like it should be possible to have firstboot be a script in /etc/event.d rather than a normal init script.

If this isn't possible, then it's all the more important to be able to quit firstboot.  You've pointed out that this could make it impossible for inexperienced users to accidentally make it impossible to log in.  However, as long as firstboot doesn't write to /etc/sysconfig/firstboot when it's cancelled, then firstboot will run again on reboot.
Comment 4 Bug Zapper 2009-06-09 09:17:07 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Chris Lumens 2009-09-08 15:15:17 EDT
I'm happy to review patches, but this is not something I have time to fix in the near term, nor do I really think there's that big of a problem here.

Note You need to log in before you can comment on or make changes to this bug.