Bug 494143 - scanimage epson2 backend fails when device has been idle, but works when run again
scanimage epson2 backend fails when device has been idle, but works when run ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 20:30 EDT by Raman Gupta
Modified: 2009-12-18 04:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raman Gupta 2009-04-04 20:30:36 EDT
Description of problem:

The first time I use scanimage after my scanner has been idle for some time, I get the following error from scanimage:

scanimage: sane_start: Error during device I/O

If I run the same command again, the scanner works perfectly.

I am using the following scan command:

scanimage --mode Gray --resolution 150


Version-Release number of selected component (if applicable):

sane-backends-1.0.19-12.fc10@i386
sane-backends-libs-1.0.19-12.fc10@i386


How reproducible:

Every time the scanner has been idle for a few minutes.


Steps to Reproduce:
1. Wait until the scanner has been idle.
2. Run scanimage.


Actual results:

scanimage: sane_start: Error during device I/O


Expected results:

It should wait for the scanner to warm up and then scan.


Additional info:

Hardware is Epson Perfection 2400 photo (AKA GT-9300 flatbed)

Output from /var/log/messages when scanner is plugged in:

# tail -f /var/log/messages | grep usb
Apr  4 20:22:04 apollo kernel: usb 1-2: new full speed USB device using uhci_hcd and address 39
Apr  4 20:22:04 apollo kernel: usb 1-2: configuration #1 chosen from 1 choice
Apr  4 20:22:04 apollo kernel: usb 1-2: New USB device found, idVendor=04b8, idProduct=011b
Apr  4 20:22:04 apollo kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr  4 20:22:04 apollo kernel: usb 1-2: Product: EPSON Scanner
Apr  4 20:22:04 apollo kernel: usb 1-2: Manufacturer: EPSON

# scanimage -L
device `epson2:libusb:001:039' is a Epson GT-9300 flatbed scanner

# cat /etc/sane.d/dll.conf | grep -v "^#"
epson2

# cat /etc/sane.d/epson2.conf | grep -Ev "^(#.*|)$"
scsi EPSON
usb
net autodiscovery
Comment 1 Raman Gupta 2009-04-05 16:40:51 EDT
The problem seems to be specific to the epson and epson2 backends. I downloaded the epkowa backend and it does not have the same issue.
Comment 2 Nils Philippsen 2009-06-17 05:55:58 EDT
I've packaged the new upstream version sane-backends-1.0.20 and submitted it for updates-testing. Please test and report back whether this improves your issue, thanks.
Comment 3 Raman Gupta 2009-07-05 02:38:29 EDT
Still get the same error with 1.0.20, using the epson2 backend, after the scanner has been idle for some time:

# scanimage --resolution 300 --mode Gray --depth 8  > foo.pnm
scanimage: sane_start: Error during device I/O
Comment 4 Bug Zapper 2009-11-18 04:58:34 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-12-18 04:11:54 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.