Bug 494183 - No downscaling with Xv on a Riva TNT 2 PCI
No downscaling with Xv on a Riva TNT 2 PCI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 08:30 EDT by Ivo Anjo
Modified: 2009-04-25 12:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-05 18:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Networkmanager video being clipped. Photo because no way to take screenshots of hardware overlay. (72.44 KB, image/jpeg)
2009-04-05 08:30 EDT, Ivo Anjo
no flags Details

  None (edit)
Description Ivo Anjo 2009-04-05 08:30:23 EDT
Created attachment 338223 [details]
Networkmanager video being clipped. Photo because no way to take screenshots of hardware overlay.

Description of problem:
05:04.0 VGA compatible controller [0300]: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] [10de:002d] (rev 15)
Downscaling of Xv doesn't seem to be working (upscaling works ok).

Version-Release number of selected component (if applicable):
Nouveau testing livecd

How reproducible:
Always

Steps to Reproduce:
1. Open a video in totem
2. Set it to 100% size
3. Resize window to be smaller
  
Actual results:
Video size is the same, the smaller window just clips it.

Expected results:
Video size should be reduced.

Additional info:
Comment 1 Ivo Anjo 2009-04-05 09:54:38 EDT
Also present on
nVidia Corporation NV6 [Vanta/Vanta LT] [10de:002c] (rev 15)
Comment 2 Ben Skeggs 2009-04-05 09:59:23 EDT
I don't believe this is a bug.  As far as I can recall, the hw overlay on nv4 (nv4/nv5/nv6) series hw can't do downscaling.  Are you able to try with the nv driver to confirm?

The blit adaptor should be able to downscale just fine however.
Comment 3 Ivo Anjo 2009-04-05 11:53:42 EDT
I thought it might be a hardware limitation too, but wasn't sure. I re-tested with the blit adaptor and downscaling works.

I tried with nv but it only offers the "NV Video Blitter", no overlay. Is there any other way to test?
Comment 4 Ben Skeggs 2009-04-05 18:41:02 EDT
Ah right, nv doesn't have any support for the overlay on that chipset.  I'll mark this as not a bug, but I'll think more about possibly using the blitter as the default Xv adaptor on at least this chipset.

Thank you!
Comment 5 Ivo Anjo 2009-04-25 12:17:50 EDT
Just for completeness, I've tested using the nvidia proprietary driver (it's kinda amazing it still works on an nvidia vanta and they haven't dropped support for it), and yeah with the overlay there is no downscaling, while using the blitter there is -- so it's the same as with nouveau.

Note You need to log in before you can comment on or make changes to this bug.