This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 494201 - Trying to delete partition from FakeRAID mapper drive
Trying to delete partition from FakeRAID mapper drive
Status: CLOSED DUPLICATE of bug 494124
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:2bb15a1f15984b7cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 10:58 EDT by David Krings
Modified: 2009-04-06 04:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 04:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (144.37 KB, text/plain)
2009-04-05 10:58 EDT, David Krings
no flags Details

  None (edit)
Description David Krings 2009-04-05 10:58:19 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.40 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 200, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/anaconda/storage/devicetree.py", line 694, in _removeDevice
    dev.disk.partedDisk.removePartition(dev.partedPartition)
  File "/usr/lib/anaconda/storage/devicetree.py", line 723, in registerAction
    self._removeDevice(d)
  File "/usr/lib/anaconda/storage/__init__.py", line 630, in createDevice
    self.devicetree.registerAction(ActionCreateDevice(device))
  File "/usr/lib/anaconda/storage/partitioning.py", line 580, in doPartitioning
    storage.createDevice(device)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1011, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 991, in deleteCB
    self.refresh(justRedraw=justRedraw)
PartitionException: Attempting to remove an extended partition that still contains logical partitions
Comment 1 David Krings 2009-04-05 10:58:26 EDT
Created attachment 338238 [details]
Attached traceback automatically from anaconda.
Comment 2 Hans de Goede 2009-04-06 04:12:01 EDT

*** This bug has been marked as a duplicate of bug 494124 ***

Note You need to log in before you can comment on or make changes to this bug.