Bug 494240 - new wired NIC gets auto connection; old wired NIC waits for user action
new wired NIC gets auto connection; old wired NIC waits for user action
Status: CLOSED DUPLICATE of bug 498207
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 492812 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 18:53 EDT by John Reiser
Modified: 2009-11-19 19:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 15:41:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-05 18:53:02 EDT
Description of problem: A new wired NIC (ethernet network interface card) which is inserted after original Fedora software install, gets an automatic connection at boot (activated with DHCP, etc.)  The old wired NIC which was present during the original Fedora software install waits for the desktop user to choose network connection (does not get activated automatically at boot using DHCP, etc.)  This inconsistent treatment of interfaces is confusing.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0.99-5.git20090326.fc11.i586
NetworkManager-glib-0.7.0.99-5.git20090326.fc11.i586
NetworkManager-gnome-0.7.0.99-5.git20090326.fc11.i586


How reproducible: always


Steps to Reproduce:
1. Fresh install Fedora 11 Beta i386 DVD with only one wired NIC in box.
2. Observe network connection management.
3. Install a second wired NIC (and switch the single network cable to use it) and observe network connection management.
  
Actual results: Wired NIC that is present at original Fedora software install does not get an active network connection until desktop user chooses which connection to activate.  Wired NIC that is added after original software install, gets activated automatically at desktop boot without requiring user action.

Expected results:  Same treatment by software regardless of when wired NIC is detected (during original software OS install, or after later hardware addition): if cable is connected, then offer that interface for user selection; but do not activate until the desktop user chooses to do so.


Additional info:
Comment 1 Basil Mohamed Gohar 2009-04-09 02:39:18 EDT
I am experiencing the same problem.  Updated rawhide as of 2009-04-08.  I have to manually select the 'System eth0' connection before it will connect.  I have a .bash_profile script that I run to make an SSH tunnel, and this will no longer work as there's no connection whenever I login.
Comment 2 Dan Williams 2009-04-09 09:44:45 EDT
This is because the DVD install did not use a network device, and anaconda will not mark devices *not* used for install to be automatically activated.  However, new devices will be automatically activated when plugged in.  I bet, if you look in your /etc/sysconfig/network-scripts/ifcfg-eth0 file, you'll find "ONBOOT=no", which was written by anaconda during install-time.  If you change that to "yes", it will work.
Comment 3 John Reiser 2009-04-09 11:10:28 EDT
Yes, I found "ONBOOT=no".  Changing to "ONBOOT=yes" and rebooting made it connect immediately without waiting for me to login and choose.
Comment 4 Niels Haase 2009-04-10 15:41:42 EDT
Thanks for filling this bug.

I seams that the problem could be solved during a change of the config file. Therefore I will setting this report to CLOSED:NOTABUG.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Dan Williams 2009-11-19 18:58:40 EST
*** Bug 492812 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2009-11-19 19:20:41 EST

*** This bug has been marked as a duplicate of bug 498207 ***

Note You need to log in before you can comment on or make changes to this bug.