Bug 494247 - gmpc --start-hidden doesn't.
gmpc --start-hidden doesn't.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gmpc (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-05 20:03 EDT by David Woodhouse
Modified: 2009-07-03 15:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.3.3-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:34:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-05 20:03:01 EDT
When I start gmpc with the --start-hidden option, it still displays its main window instead of just going into the notification area.
Comment 1 Adrian Reber 2009-04-07 06:43:30 EDT
I cannot reproduce it. gmpc starts hidden on F10 and I also did a test installation of F11 beta (in a KVM) and it also starts hidden. This is using the default gnome setup (no compiz). In what environment do you see that it does not start hidden?
Comment 2 David Woodhouse 2009-04-07 18:24:53 EDT
It's a fairly standard GNOME desktop, installed as F9, updated to F10 and then to F11. When I run 'gmpc --start-hidden', I get a gmpc window which is minimised, rather than getting _no_ gmpc main window.
Comment 3 Adrian Reber 2009-04-08 04:05:56 EDT
Ah, okay. I will fix it.
Comment 4 Adrian Reber 2009-04-08 07:27:24 EDT
The code seems to do the right thing. It tests if the there is tray icon and if there is a tray icon it hides the window and if there is no tray icon it just minimizes it. The test if there is tray icon unfortunately returns false on startup, although the tray icon is initialized earlier. Seems to be some kind of problem with the timing.

The error still exists in the new 0.18.0 version. If I build it, however, with --enable-eggtrayicon it works correctly for me. I will update gmpc to 0.18.0 on rawhide and build it with --enable-eggtrayicon.

It probably will take a few days until I can coordinate the rebuild of all application depending on libmpd (which also needs to be updated for the new gmpc version).
Comment 5 Bug Zapper 2009-06-09 09:19:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2009-06-24 10:00:49 EDT
xfce4-mpc-plugin-0.3.3-4.fc11,xfmpc-0.1.0-2.fc11,guimup-0.1.4-6.d.fc11.1,gimmix-0.5.2-3.fc11,gmpc-0.18.0-1.fc11,libmpd-0.18.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xfce4-mpc-plugin-0.3.3-4.fc11,xfmpc-0.1.0-2.fc11,guimup-0.1.4-6.d.fc11.1,gimmix-0.5.2-3.fc11,gmpc-0.18.0-1.fc11,libmpd-0.18.0-1.fc11
Comment 7 Fedora Update System 2009-06-26 22:43:18 EDT
xfce4-mpc-plugin-0.3.3-4.fc11, xfmpc-0.1.0-2.fc11, guimup-0.1.4-6.d.fc11.1, gimmix-0.5.2-3.fc11, gmpc-0.18.0-1.fc11, libmpd-0.18.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xfce4-mpc-plugin xfmpc guimup gimmix gmpc libmpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6969
Comment 8 Fedora Update System 2009-07-03 15:34:11 EDT
xfce4-mpc-plugin-0.3.3-4.fc11, xfmpc-0.1.0-2.fc11, guimup-0.1.4-6.d.fc11.1, gimmix-0.5.2-3.fc11, gmpc-0.18.0-1.fc11, libmpd-0.18.0-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.