Bug 494252 - gnome-keyring-daemon crashing
gnome-keyring-daemon crashing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-05 20:25 EDT by David Woodhouse
Modified: 2015-03-03 17:40 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 14:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-05 20:25:36 EDT
Since upgrading from F-10 to rawhide a few days ago, I've sometimes noticed that ssh-agent isn't present in my session after I log in through gdm. Other times, it works normally.
Comment 1 Matěj Cepl 2009-04-06 11:32:57 EDT
well, ssh-agent is not present, because it should be replaced by gnome-keyring. But that isn't apparently started either. And gnome-keyring should be started by gnome-session, so reassigning, but adding "me too".
Comment 2 Matthias Clasen 2009-04-06 13:35:46 EDT
gnome-keyring-daemon probably crashed. I've filed http://bugzilla.gnome.org/show_bug.cgi?id=577798 for the crash issues I am seeing.
Comment 3 Warren Togami 2009-04-06 13:48:20 EDT
gnome-keyring-daemon is run by default.  For me the first attempt to use ssh pops up a passphrase dialog and login works.  Subsequent attempts however print:

Error reading response length from authentication socket.
warren@XX.XXX.XXX.XX's password: 

And gnome-keyring-daemon died.  This began a few days ago for me.
Comment 4 Yanko Kaneti 2009-04-07 04:49:10 EDT
Here the difference between not crashing and crashing is 2.26.0-1 vs 2.26.0-2,
which points to the egg-endless-loop. Excerpt of the backtrace added here
http://bugzilla.gnome.org/show_bug.cgi?id=575247
Comment 5 Matthias Clasen 2009-04-07 14:01:27 EDT
I've reverted the egg-endless-loop patch now, and commented on the upstream bug.

Note You need to log in before you can comment on or make changes to this bug.