Bug 494263 - python-libs segfault during setroubleshoot
python-libs segfault during setroubleshoot
Status: CLOSED DUPLICATE of bug 492737
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 01:39 EDT by Allen Kistler
Modified: 2009-04-06 09:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 09:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Kistler 2009-04-06 01:39:15 EDT
Description of problem:
Attempting to run setroubleshoot browser ("sealert -b") fails.
Error messages in /var/log/messages report a segfault in libpython.

Version-Release number of selected component (if applicable):
python-libs-2.6-7.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Try to run "sealert -b"
   either from command line or as System-Tools/SELinux-Troubleshooter

Actual results:
Nothing happens on screen.
Errors logged in /var/log/messages (see below)

Expected results:
Troubleshooter opens

Additional info:
These are the other packages involved, but I'm filing against python, since that's where the segfault appears to occur.

dbus-1.2.12-1.fc11.i586
setroubleshoot-2.1.8-1.fc11.i586
setroubleshoot-server-2.1.8-1.fc11.i586

/var/log/messages as follows...

Apr  5 23:24:15 localhost kernel: setroubleshootd[2964]: segfault at 95 ip 05f81ca2 sp bfacf980 error 4 in libpython2.6.so.1.0[5f01000+14f000]

Apr  5 23:24:15 localhost setroubleshoot: [dbus.ERROR] could not start dbus: org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /lib/dbus-1/dbus-daemon-launch-helper received signal 11

Apr  5 23:24:15 localhost setroubleshoot: [dbus.proxies.ERROR] Introspect error on :1.44:/org/fedoraproject/Setroubleshootd: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Apr  5 23:24:15 localhost setroubleshoot: [dbus.ERROR] could not start dbus: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.44 was not provided by any .service files
Comment 1 James Antill 2009-04-06 09:47:11 EDT

*** This bug has been marked as a duplicate of bug 492737 ***

Note You need to log in before you can comment on or make changes to this bug.