Bug 494264 - Recent kernel update breaks nouveau
Recent kernel update breaks nouveau
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 01:58 EDT by Alex Hudson (Fedora Address)
Modified: 2009-05-10 13:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-10 13:47:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from nouveau crash (8.27 KB, text/plain)
2009-04-06 01:58 EDT, Alex Hudson (Fedora Address)
no flags Details
Xorg.0.log from nouveau crash in rawhide. (32.88 KB, text/plain)
2009-05-08 11:42 EDT, Alex Hudson (Fedora Address)
no flags Details

  None (edit)
Description Alex Hudson (Fedora Address) 2009-04-06 01:58:10 EDT
Created attachment 338288 [details]
Xorg.0.log from nouveau crash

Description of problem:

Updated to new kernel yesterday; desktop no longer comes up at all - boot process just sits on a blank screen with a flashing cursor. Xorg appears to be spinning in a cycle of not being able to start, but constantly retrying.

Xorg.0.log (attached) appears to indicate a problem reading from a bios:

(II) NOUVEAU(0): Attempting to load BIOS image from PRAMIN
(II) NOUVEAU(0): ... appears to be valid
(II) NOUVEAU(0): BIT BIOS found
(II) NOUVEAU(0): Bios version 60.86.47.00
(--) NOUVEAU(0): Parsing VBIOS init table 0 at offset 0xC4A1
(EE) NOUVEAU(0): ========== unknown reg 0x0002130C ==========
(EE) NOUVEAU(0): ========== unknown reg 0x00021218 ==========
(EE) NOUVEAU(0): ========== unknown reg 0x0002004C ==========
(EE) NOUVEAU(0): ========== unknown reg 0x00020060 ==========

Version-Release number of selected component (if applicable):

kernel-2.6.27.21-170.2.56.fc10.x86_64

How reproducible:

Always

Additional info:

Booted to kernel-2.6.27.19-170.2.35.fc10.x86_64 and it works great.
Comment 1 Gireesh Sreekantan 2009-04-07 04:12:42 EDT
Hi Alex,
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) as individual uncompressed file attachment using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

Finally the version of xorg-x11-drv-nouveau would also helpful.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance for taking the time to provide this information.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Alex Hudson (Fedora Address) 2009-05-08 11:41:55 EDT
It now also doesn't work in Rawhide:

kernel-2.6.29.2-126.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-33.20090501gitf69b34a.fc11.x86_64

I'll attach an Xorg.0.log from a recent attempt; looks like it errors in a totally different way now on Rawhide but is otherwise identically broken.

I don't have an /etc/X11/xorg.conf (well, I do now, but only to select the 'nv' driver since nouveau is broken), and I assume my previous log is still ok.
Comment 3 Alex Hudson (Fedora Address) 2009-05-08 11:42:31 EDT
Created attachment 343122 [details]
Xorg.0.log from nouveau crash in rawhide.
Comment 4 Ben Skeggs 2009-05-08 21:18:36 EDT
Sorry for that, a recent Xorg update broke all versions of nouveau prior to 0.0.12-34.  Can you update to that?
Comment 5 Alex Hudson (Fedora Address) 2009-05-10 13:47:20 EDT
Yup, updated - seems to work fine again, cheers!

Note You need to log in before you can comment on or make changes to this bug.