Bug 494265 - java-1.6.0-openjdk conflict with upstream
java-1.6.0-openjdk conflict with upstream
Status: CLOSED CANTFIX
Product: Fedora EPEL
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
el5
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 01:59 EDT by Frank Büttner
Modified: 2009-12-31 00:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 07:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2009-04-06 01:59:15 EDT
Description of problem:
As far as I know, EPEL packages shut not replace upstream packages.
But this package has the same name as java under 5.3 of the upstream package.
So I think it, must be removed for EPEL and 5.3.


Version-Release number of selected component (if applicable):



How reproducible:
every time when the EPEL repo is enabled.


Steps to Reproduce:
1. run yum info java-1.6.0-openjdk
.
  
Actual results:
The package of EPEL is found.

Expected results:
That the package of the upstream vendor is found.
Comment 1 Lubomir Rintel 2009-04-06 06:21:08 EDT
There's nothing EPEL can do about this.
You may want to report it to your operating system vendor.
Comment 2 manuel wolfshant 2009-04-06 06:44:19 EDT
The problem comes from the version comparison:
 distro: java-1.6.0-openjdk-1.6.0.0-0.25.b09.el5.i386.rpm
 EPEL:   java-1.6.0-openjdk-1.6.0.0-1.0.b12.el5.2.i386.rpm

And the proper fix is for EPEL to remove the package from the repos.
Comment 3 Lubomir Rintel 2009-04-06 06:48:19 EDT
It's not. This won't fix broken configuration.
Proper fix is for distribution vendor to bump revision.
Comment 4 Frank Büttner 2009-04-06 06:51:12 EDT
This is on of EPEL policy.
"Thus packages from EPEL should never replace packages from the target base distribution - including those on the base distribution as well as layered products; kernel-modules further are not allowed, as they can disturb the base kernel easily." And this is the case now. So you have something to do.
Comment 5 manuel wolfshant 2009-04-06 06:55:30 EDT
Frank, the problem comes from the fact the RHEL 5.3 added to the distro a package that was already included in EPEL, without warning and with an older release than the one existing in EPEL.

Unfortunately the only fix is to remove the package from the repo (minus the -plugin package, which is not provided by the distro.. go figure)
Comment 6 manuel wolfshant 2009-04-06 06:56:13 EDT
And yes, I know that those who have already installed the EPEL version will have keep having it
Comment 7 manuel wolfshant 2009-04-06 06:57:02 EDT
grr, to be read "will keep having it until the vendor bumps the version "
Comment 8 Lubomir Rintel 2009-04-06 07:18:21 EDT
Sorry, I'm not into half-assed solutions.
Comment 9 Paul Johnson 2009-12-31 00:07:54 EST
This should not be closed. It can be fixed.

Centos should withdraw their oudated & incomplete offering of java-1.6.0.  or they should add a plugin rpm, just as EPEL had done before (which was working fine).  Why does Centos offer b9, anyway??

yum can't understand what's going on, however.  The java packages from EPEL work, but yum keeps trying to install the OLDER versions from Centos rather than leaving the NEWER working versions in place.  I believe this is due to the EPOCH settings in the RPM packages.

If Centos continues to refuse to fix it, the EPEL should take the source RPM used by Centos, fix it so it creates the proper plugin package, and the plugin package should be put on  EPEL. 

This really is Centos's fault because they were late to the game, EPEL had working versions before, and nobody has justified the way Centos did this.  But EPEL can work around this to offer the plugin package.

Note You need to log in before you can comment on or make changes to this bug.