Bug 494302 (javaws) - Certain Java WebStart Applications don't work on F11 beta, x86_64
Summary: Certain Java WebStart Applications don't work on F11 beta, x86_64
Status: CLOSED ERRATA
Alias: javaws
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk   
(Show other bugs)
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: man lung wong
QA Contact: Fedora Extras Quality Assurance
URL: http://www.sweethome3d.eu/SweetHome3D...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-04-06 10:10 UTC by Arnold Sutter
Modified: 2013-05-30 20:27 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 18:44:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot with working javaws application (101.88 KB, image/jpeg)
2010-01-08 21:03 UTC, Arnold Sutter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 216 None None None Never

Description Arnold Sutter 2009-04-06 10:10:39 UTC
Description of problem:
Can't start Java WebStart Application at http://www.sweethome3d.eu/SweetHome3D.jnlp

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-17.b14.fc11.x86_64

How reproducible:
With Firefox, click to above URL. 
If downloaded, start the SweetHome3D.jnlp with javaws: 

$ javaws SweetHome3D.jnlp
netx: Spec version not supported (supports 1.0)

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Error message: "netx: Spec version not supported (supports 1.0)"


Expected results:
Java Application starts


Additional info:
The actual request was to manage a Brocade FC-Switch with attached 
JNLP XML-File. The above URL is a reproducer I could find on the WEB.

Comment 1 Deepak Bhole 2009-04-06 19:11:41 UTC
NetX only supports 1.0 specs at the moment. The site in question uses spec 1.5+. The application does need 1.5 (i.e. editing .jnlp file to say spec 1.0 wouldn't work), so there is no IcedTea based workaround at the moment as it requires javax.jnlp classes that don't exist in IcedTea.

I have not done an analysis of 1.0 vs 1.5 spec yet -- I will look into it, and will keep this issue open in the mean time. Thanks for reporting.

Comment 2 Bug Zapper 2009-06-09 13:19:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Omair Majid 2009-07-07 16:54:08 UTC
Upstream has added support for JNLP 1.5 and 6.0 files.

Comment 4 Oliver Ruebenacker 2009-08-06 23:32:53 UTC
When will it be fixed for F11? Thanks!

Comment 5 Oliver Ruebenacker 2009-08-06 23:35:04 UTC
Why is this bug not high priority and high severity, considering it blocks entire applications? Thanks!

Comment 6 Deepak Bhole 2009-08-07 01:39:05 UTC
We don't have full 6.0 and 1.5 support upstream yet so we can't cut a release midway just for 1 bug. It is close though. We will probably have an update for Fedora shortly (most likely a 1-3 week time frame) that includes the fixes for this issue.

Comment 7 Oliver Ruebenacker 2010-01-07 16:09:55 UTC
Now we have 5 months later and Fedora 12 and it is still not working. What's going on?

Comment 8 Oliver Ruebenacker 2010-01-07 16:12:36 UTC
How can we add Fedora 12 to the bug description, or does that require a separate bug report?

Comment 9 Deepak Bhole 2010-01-07 22:26:30 UTC
This is already fixed. I just tried it in F12 and it is working for me with java-1.6.0-openjdk-1.6.0.0-33.b16.fc12.i686

What version of OpenJDK are you using?

Comment 10 Oliver Ruebenacker 2010-01-07 22:34:07 UTC
  Doesn't work for me.

# java -version
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.6) (fedora-33.b16.fc12-i386)
OpenJDK Server VM (build 14.0-b16, mixed mode)

  Also, if it is fixed, why is this not reflected on Bugzilla?

Comment 11 Deepak Bhole 2010-01-08 15:53:40 UTC
Fell through the cracks (it was not fixed by me). Anyway, if you are still seeing it, I can't close it now.

What happens when you run 'javaws http://www.sweethome3d.eu/SweetHome3D.jnlp'?

Also, are you on a 64-bit system or 32?

Comment 12 Jerry Amundson 2010-01-08 17:04:50 UTC
(In reply to comment #10)
>   Doesn't work for me.

FWIW, using
fc11.x86_64 and fc12.i386 : works for me on both.

Comment 13 Jerry Amundson 2010-01-08 17:07:52 UTC
Reporter, has your specific test case with Brocade FC-Switch management been resolved?

Comment 14 Arnold Sutter 2010-01-08 21:03:52 UTC
Created attachment 382556 [details]
Screenshot with working javaws application

On a newly installed F12, x86_64 Installation, I've navigated to the URL in question and I could indeed run the Java Web application. 

Here are my Java-related packages: 

[root@shuttle2 ~]# rpm -qa|egrep -i "java"
java-1.5.0-gcj-1.5.0.0-29.fc12.x86_64
java-1.6.0-openjdk-1.6.0.0-33.b16.fc12.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-33.b16.fc12.x86_64
ant-javamail-1.7.1-12.fc12.x86_64
java_cup-0.10k-3.x86_64
java-1.6.0-openjdk-devel-1.6.0.0-33.b16.fc12.x86_64
tzdata-java-2009o-2.fc12.noarch
javahelp2-2.0.05-8.fc12.noarch
java-1.6.0-openjdk-javadoc-1.6.0.0-33.b16.fc12.x86_64

So for me, it seems that this bug is "solved".

Thanks & best Regards, 

Arnold

Comment 15 Oliver Ruebenacker 2010-01-08 21:20:26 UTC
(In reply to comment #11)
> Fell through the cracks (it was not fixed by me). Anyway, if you are still
> seeing it, I can't close it now.
> 
> What happens when you run 'javaws http://www.sweethome3d.eu/SweetHome3D.jnlp'?

  That one runs.

> Also, are you on a 64-bit system or 32?  

  I don't know, maybe 32. Maybe I should file a separate bug then?

Comment 16 Jerry Amundson 2010-01-08 21:40:01 UTC
(In reply to comment #10)
>   Doesn't work for me.

Please provide more details.
What browser?
What happens?
etc.

Comment 17 Oliver Ruebenacker 2010-01-08 22:02:02 UTC
(In reply to comment #16)
> (In reply to comment #10)
> >   Doesn't work for me.
> 
> Please provide more details.
> What browser?
> What happens?
> etc.  

  With Firefox 3.5.6 on F12, I click the link. It asks what to open with, offering javaws, which I choose. Then is says "download complete" and nothing more happens.

  When I try webstart from a terminal, I get:

$javaws http://vcell.org/webstart/Rel/vcell.jnlp
netx: Unexpected net.sourceforge.jnlp.ParseException: Invalid XML document syntax. at net.sourceforge.jnlp.Parser.getRootNode(Parser.java:1200)

Comment 18 man lung wong 2010-01-11 15:49:35 UTC
Looking into it right now.

Man Lung Wong

Comment 19 man lung wong 2010-01-13 18:44:44 UTC
http://www.w3.org/TR/REC-xml/

If you look under section 2.4 in the above link, double quotes in an attribute should be represented as """ not \" as in vcell.jnlp, which caused the problem (so if you change \" to """, then it should work fine). If there is any other problems, feel free to reopen the bug.

Thanks,
Man Lung Wong

Comment 20 Oliver Ruebenacker 2010-01-13 19:55:54 UTC
Thank you! Indeed, after the quotes have been replaced, it works now. It turns out, although the problem only occurred under Linux, and not under Win or Mac, it was not a Linux problem. Although, it would be nice if netx would be as tolerant of XML syntax errors as its Win and Mac counterparts apparently are.


Note You need to log in before you can comment on or make changes to this bug.