Bug 494305 - releasing pointer grab gives focus problems
releasing pointer grab gives focus problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-06 06:33 EDT by Jens Petersen
Modified: 2009-04-21 19:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 19:17:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-04-06 06:33:12 EDT
Description of problem:
When I press Ctrl-Alt to release the pointer from a virtual console
I am unstable to get proper focus on the host desktop focus without
bringing the pointer over the console window again and right clicking
on the host desktop to bring up the host desktop menu.

Version-Release number of selected component (if applicable):
virt-manager-0.6.1-1.fc10

How reproducible:
every time

Steps to Reproduce:
1. enter console and click to have pointer grabbed
2. press Ctrl-Alt
3. try to right click on host desktop
  
Actual results:
3. nothing

Expected results:
3. desktop menu should appear

Additional info:
A workaround is to take the pointer in and out the console window
again: then it is possible to bring up the desktop menu with button3.

This used to work in earlier releases.
Comment 1 Jens Petersen 2009-04-06 06:35:11 EDT
(Oops, taking off F11Target list since I don't know if this happens
with newer version in rawhide.  If someone could confirm that it
would be good.)
Comment 2 Daniel Berrange 2009-04-06 06:55:43 EDT
What GTK-VNC version do you have ?
Comment 3 Mark McLoughlin 2009-04-20 06:25:17 EDT
Jens?
Comment 4 Jens Petersen 2009-04-20 23:57:44 EDT
Sorry: gtk-vnc-0.3.8-4.fc10.x86_64
Comment 5 Daniel Berrange 2009-04-21 06:02:19 EDT
Can you confirm whether the problem from comment #1 still occurs with this latest gtk-vnc-0.3.8-4.fc10. When the bug was reported, this version was not yet pushed to F10 updates stable.  The 0.3.8-4.fc10 build has a fix for pretty much exactly the scenario you describe in the initial report, so I'm surprised if this is still a problem
Comment 6 Jens Petersen 2009-04-21 19:17:33 EDT
Ok I think you're right and this seems to be fixed now.  It might have happened that I had updated and not restarted v-m or something earlier.

I'll close this out and re-/open if I should see any problem later.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.