Bug 494316 - satellite repodata cache won't get updated after sync
satellite repodata cache won't get updated after sync
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
wes hayutin
:
Depends On:
Blocks: 485807
  Show dependency treegraph
 
Reported: 2009-04-06 07:28 EDT by Tomas Lestach
Modified: 2009-09-10 14:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-04-06 07:28:52 EDT
Description of problem:
I had a client registered to a Satellite and assigned to a RHEL channel (rhel-i386-server-5).

# yum list all
didn't list any packages from the default RHEL channel even after
#yum clean all
on the client or "Update" button on the Satellite WEBUI channel page.

According to WEBUI there were 5142 in the RHEL channel.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090401.0-x86_64

Steps to Reproduce:
1. Synchronize a RHEL channel on a satellite.
My first sync failed for some reason and the WEBUI showed 0 packages in the channel. (Not sure how to reproduce it - maybe interrupt the sync process - but the step seems to be important.)
The result PROBABLY was that a repodata cache with 0 packages in the channel was created. 
2. I run the satellite-sync again. The sync was successful and according to WEBUI 5142 packages were in the RHEL channel.
3.
Run
# yum repolist
on the client to make sure, it is subscribed to the channel.
4.
Run
# yum list all
on the client
  
Actual results:

Commands on client:
# yum list available (or all)
doesn't list any package from the RHEL channel.
# yum install <package>
fails, if the <package> is included in the RHEL channel according to WEBUI.
# yum search <package>
doesn't find the package that is definitely included in the channel.

Expected results:
I expect aligned information - on WEBUI and for the clients. If WEBUI shows over 5000 packages in the channel, the client shall have there packages available.

Additional info:
It seems that the channel meta data will be created once and won't be updated any again.
When I removed /var/cache/rhn/repodata/ on the satellite and run satellite-sync again, the cache will be re-created correctly.

The reason of the problem can be similar to BZ#493817.
Comment 1 Brandon Perkins 2009-04-07 11:39:19 EDT
Approved.   But please check that the problem isn't purely because of slow or under-resourced hardware.
Comment 3 wes hayutin 2009-04-23 14:10:23 EDT
works after a yum clean all
verified 4/22.2 build
Comment 4 Milan Zázrivec 2009-08-11 05:08:18 EDT
Verified in stage -> RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 14:41:11 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.